Bug 477049 - non-evdev-managed gnome keyboard model causes problems
non-evdev-managed gnome keyboard model causes problems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 15:49 EST by Richard Guest
Modified: 2009-01-17 00:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-17 00:49:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Guest 2008-12-18 15:49:55 EST
I discovered this problem, after a Fedora 10 upgrade (from 9) on both my Dell Latitude D610 laptop and my Dell desktop with Kinesis USB keyboard. I had issues with some control keys sending incorrect keycodes (e.g. left arrow sent Alt_R, Alt_L sent Delete and up arrow send PrintScr... there were more).

The solution for me was to set the 'Keyboard Model' in gnome-keyboard-properties to 'Evdev-managed keyboard' and everything's fine.

Changing the 'Keyboard Model' back (to 'Dell Latitude Series Laptop', for example) reproduces the problem 100% of the time.
Comment 1 Matthias Clasen 2009-01-17 00:49:23 EST
That is not a bug. X is using the evdev driver, thus "Evdev-managed keyboard" is the correct configuration.

Note You need to log in before you can comment on or make changes to this bug.