Bug 477058 - Unreadable fonts in OpenOffice/Word and gftp (and other apps?)
Unreadable fonts in OpenOffice/Word and gftp (and other apps?)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fontpackages (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Nicolas Mailhot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 16:16 EST by John Curcio
Modified: 2008-12-20 06:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 08:33:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Curcio 2008-12-18 16:16:12 EST
Description of problem:Fonts in OpenOffice and gftp (and other apps?) not readable


Version-Release number of selected component (if applicable):Fedora 10


How reproducible:Very reproduceable with OpenOffice Word


Steps to Reproduce:
1.Open Word document and look at menu items
2.
3.
  
Actual results:Menu items are unreadable


Expected results:Readable items


Additional info:Attaching screen capture.
Have seen behaviour in KDE and Gnome on two seperate machines ... 
Also attaching list of all RPM packages which have the name fonts in them below ->

[jcurcio@johns-fedora10 ~]$ uname -a
Linux johns-fedora10 2.6.27.7-134.fc10.i686 #1 SMP Mon Dec 1 22:42:50 EST 2008 i686 i686 i386 GNU/Linux                                                       
[jcurcio@johns-fedora10 ~]$ vi it  

                                            
[jcurcio@johns-fedora10 ~]$ rpm -qa | grep fonts                               
jomolhari-fonts-0.003-5.fc10.noarch                                            
lohit-fonts-punjabi-2.3.1-1.fc10.noarch                                        
khmeros-fonts-base-5.0-3.fc10.noarch                                           
xorg-x11-fonts-ISO8859-15-75dpi-7.2-6.fc9.noarch                               
xorg-x11-fonts-ISO8859-14-75dpi-7.2-6.fc9.noarch                               
lohit-fonts-hindi-2.3.1-1.fc10.noarch                                          
xorg-x11-fonts-ISO8859-9-100dpi-7.2-6.fc9.noarch                               
dejavu-fonts-experimental-2.26-2.fc10.noarch                                   
paktype-fonts-2.0-2.fc8.noarch                                                 
lohit-fonts-tamil-2.3.1-1.fc10.noarch                                          
thaifonts-scalable-0.4.9-3.fc9.noarch                                          
smc-fonts-meera-04.1-1.fc10.noarch                                             
lohit-fonts-maithili-2.3.1-1.fc10.noarch                                       
bitmap-fonts-0.3-6.fc10.noarch                                                 
cjkunifonts-uming-0.2.20080216.1-10.fc10.noarch                                
VLGothic-fonts-20081029-1.fc10.noarch                                          
xorg-x11-fonts-ISO8859-15-100dpi-7.2-6.fc9.noarch                              
xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch
dejavu-fonts-2.26-2.fc10.noarch
lohit-fonts-bengali-2.3.1-1.fc10.noarch
lklug-fonts-0.2.2-6.fc10.noarch
abyssinica-fonts-1.0-2.fc8.noarch
un-core-fonts-dotum-1.0.2-0.6.080608.fc10.noarch
lohit-fonts-gujarati-2.3.1-1.fc10.noarch
lohit-fonts-oriya-2.3.1-1.fc10.noarch
urw-fonts-2.4-6.fc10.noarch
msttcore-fonts-2.0-2.noarch
xorg-x11-fonts-100dpi-7.2-6.fc9.noarch
xorg-x11-fonts-Type1-7.2-6.fc9.noarch
xorg-x11-fonts-ISO8859-9-75dpi-7.2-6.fc9.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.2-6.fc9.noarch
texlive-texmf-errata-fonts-2007-4.fc9.noarch
kacst-fonts-2.0-1.fc10.noarch
lohit-fonts-kannada-2.3.1-1.fc10.noarch
texlive-texmf-fonts-2007-26.fc10.noarch
liberation-fonts-1.04.92-1.fc10.noarch
xorg-x11-fonts-75dpi-7.2-6.fc9.noarch
xorg-x11-fonts-ISO8859-14-100dpi-7.2-6.fc9.noarch
padauk-fonts-2.4-2.fc10.noarch
stix-fonts-0.9-7.fc10.noarch
lohit-fonts-telugu-2.3.1-1.fc10.noarch
ghostscript-fonts-5.50-19.fc10.noarch
xorg-x11-fonts-misc-7.2-6.fc9.noarch
linux-libertine-fonts-4.1.8-1.fc10.noarch
[jcurcio@johns-fedora10 ~]$


Thanks for your help :-)
John C
Comment 1 Nicolas Mailhot 2008-12-19 08:33:20 EST
Since you do not have the fontpackages rpm installed I don't see how this can be constructed as a fontpackages bug.

Please reopen against the right component when you've found out what your problem was.

If it fails for every app with every font this is most probably not a font problem but an xorg or fontconfig problem. In any way with so little info and without even a screenshot no one can really help you.
Comment 2 John Curcio 2008-12-19 20:10:29 EST
Your attitude SUCKS! Rather than trying to assist me in further clarifying where the problem is you chose to simply close the issue and leave it entirely up to me to debug the issue. And since I told you that I had attached a screenshot, either you missed something or I didn't attach it properly ... rather that attempt to look further or maybe give someone the benefit of the doubt you instead chose to throw your hands in the air and be rude.

Thanks for your complete lack of assistance. I guess it's good thing you're not in a service industry!
Comment 3 Ben Laenen 2008-12-20 06:54:26 EST
It looks like you didn't attach a screenshot. Please try again, because "bad rendering" can mean anything.

Note You need to log in before you can comment on or make changes to this bug.