Bug 477062 - multi-org, system sdc has access to private channels that were previously public.
multi-org, system sdc has access to private channels that were previously pub...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
wes hayutin
http://scooby.rdu.redhat.com/rhn/syst...
:
Depends On:
Blocks: space04
  Show dependency treegraph
 
Reported: 2008-12-18 16:26 EST by wes hayutin
Modified: 2009-01-22 11:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 11:31:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2008-12-18 16:26:18 EST
Description of problem:

Create two orgs A and B, w/ trust relationships
create a public shared channel in A, called mychannel

Register a system in B
Change the base channel to the system to "mychannel"

In org A change mychannel from public to private

Org B 
system still has access to mychannel in the SDC.
The channel is visible, and packages are visible

Required change.

When the channel is moved to private, the consuming orgs should not be able to see
the channel
Comment 1 Shannon Hughes 2009-01-05 15:12:31 EST
looks like this functionality is missing. we need to loop through the systems of orgs that are bumped from changing public->private or protected->private. 

moving back to zeus queue
Comment 2 Jesus M. Rodriguez 2009-01-07 15:57:26 EST
be9df755f871c73ee302bb57d0341fd371ea452a
Comment 3 Jesus M. Rodriguez 2009-01-14 22:41:40 EST
Followed test plan in original comment.
After logging in with the second org, the system had a base channel of
(none). And access to the shared channel is no longer.

Note You need to log in before you can comment on or make changes to this bug.