Bug 477069 - FC10 Kernel doesn't work with www.nvidia.com drivers.
FC10 Kernel doesn't work with www.nvidia.com drivers.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 17:04 EST by Khaled
Modified: 2008-12-22 11:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 11:10:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Khaled 2008-12-18 17:04:36 EST
Hello.

I know the nvidia driver is not part of the fedora project, but I'm pretty sure that the problem is with the FC10 kernel (the same driver worked for me on FC9 and Ubuntu 8.10).

I upgraded from FC9 to FC10. As soon as I installed the Nvidia prop. driver (NVIDIA-Linux-x86-177.82-pkg1), X stopped working (and would freeze, must hard-reset it). The only way i can access my system at all was to change the default runlevel to 3. The kernel installed was kernel-PAE-2.6.27.5-117.fc10.i686. 

I tried the older nvidia driver (NVIDIA-Linux-x86-177.80-pkg1), same problem.

I suspected that the problem was the kernel, since that driver was working for me before. I tried changing the kernel to kernel-2.6.27.5-117.fc10.i686 (no PAE), recompiled the nvidia driver - same problem.

I also tried the newer kernels (kernel-2.6.27.7-134.fc10 and kernel-PAE-2.6.27.7-134.fc10.i686), same problem with both 177.80 and 177.82 drivers. (Ofcourse, I recompiled the driver every time)

The only way I could get the system to work was to downgrade to kernel-2.6.25.10-86.fc9.i686 (which I knew worked because I had that with my FC9).

So now I have a working FC10 distro with an FC9 Kernel.

As a side point: the same driver worked for me on Ubuntu 8.10, which also uses the 2.6.27 kernel.

Thanks.
Comment 1 Khaled 2008-12-18 17:17:02 EST
Addendum:

If it was a fc10kernel/nvidia problem, I doubt I'd be the first person reporting it. Here is some hardware information, in case it matters:

CPU:  Intel Core 2 Duo E6550
GPU:  Nvidia Geforce 8800GT
RAM:  Crucial 4GB DDR2-1066 (showing up as 2.5GB)
MB:   Gigabyte EP45-DS3R (Has Intel P45 chipset)

All of the tests in the original comment were done on the same machine.
Comment 2 Chuck Ebbert 2008-12-22 11:10:53 EST
Fedora 10 is using not-yet-upstream DRM code that may require changes to the nVidia drivers.

Note You need to log in before you can comment on or make changes to this bug.