Bug 47708 - rpm returns segmentation fault
rpm returns segmentation fault
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 12:26 EDT by Gunendra Patil
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 12:26:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gunendra Patil 2001-07-06 12:26:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
All the following commands are returning segmentation fault (core doum) 
for me:

rpm -qa
rpm --rebuild
rpm --nodep -qa
To get more details I tried 

rpm -qa -vv
rpm -rebuld -vv

This gives me lot more data on screen, however after a while it again 
gives me same error.




How reproducible:
Always

Steps to Reproduce:
1. rpm -qa
2. rpm -rebuild
3. rpm -qa -vv --nodep
	

Actual Results:  segmentaion fault (core dump)

Additional info:

I am getting this problem, since I tried to uninstall (erase) some 
packages (namely tetex) from KDE package manager. It gave me a first error 
that time , after that all graphical package managers as well rpm is 
crashing..

I think this is related with some dependancy problem rpm database. Or may 
be rpm DB is corrupted... In any case need to know how to recover from 
that..
Comment 1 Jeff Johnson 2001-07-06 12:51:11 EDT
Please try the rpm-4.0.3-0.57 packages from Raw Hide or from
	ftp://ftp.rpm.org/pub/rpm/test-4.0.3
as I believe that a "rpm --rebuilddb" will repair (by removing)
a damaged header in your database. After fixing the database
you should either
	a) reinstall rpm-4.0.2
	b) update kpackage and other executables that use rpmlib
Read: everything should use the same version of rpm, either 4.0.2 or 4.0.3.

If the above doesn't work, please reopen this bug, and include a pointer
to a copy of your database (attachments won't work)
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm
and I'll get you a fix.

Note You need to log in before you can comment on or make changes to this bug.