Bug 477086 - RTL8187B wireless chipset fails to hold a connection for more than 5 to 10 minutes
RTL8187B wireless chipset fails to hold a connection for more than 5 to 10 mi...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 20:09 EST by Ian Weller
Modified: 2009-01-14 04:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 479860 (view as bug list)
Environment:
Last Closed: 2009-01-13 16:25:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (32.32 KB, text/plain)
2009-01-12 15:54 EST, Dave Russell
no flags Details
ifconfig output (1.59 KB, text/plain)
2009-01-12 15:54 EST, Dave Russell
no flags Details
iwconfig output (460 bytes, application/octet-stream)
2009-01-12 15:55 EST, Dave Russell
no flags Details
/var/log/messages output (348.66 KB, text/plain)
2009-01-12 15:56 EST, Dave Russell
no flags Details

  None (edit)
Description Ian Weller 2008-12-18 20:09:32 EST
Description of problem:
An Encore ENUWI-G2 wireless USB adapter, which contains the Realtek RTL8187B chipset, fails to hold a connection for more than about 5 to 10 minutes. NetworkManager still recognizes it as connected, but no packets appear to go through.

Version-Release number of selected component (if applicable):
kernel-2.6.27.7-134.fc10.i686

How reproducible:
Every time.

Steps to Reproduce:
1. Plug in adapter, connect with NetworkManager
2. Connect to a network, start utilizing
  
Actual results:
Dies after about 7 to 10 minutes.

Expected results:
Connection stays active.
Comment 1 Dave Russell 2009-01-12 13:00:32 EST
Can you re-check this with the latest kernel?

I'm using 2.6.27.9-159.fc10.i686 and getting slightly different results.

Now the connection stays up, and associated, but no packets can go through at all.

Even if I reconnect, it's still dead as a dodo.

If it's the same for you on the latest kernel I'll upload logs etc.
Comment 2 Dave Russell 2009-01-12 15:13:39 EST
[root@cobwebs ~]# lsusb
Bus 002 Device 002: ID 0bda:8197 Realtek Semiconductor Corp. RTL8187B Wireless Adapter
[root@cobwebs ~]# uname -a
Linux cobwebs.darkglobe.int 2.6.27.9-159.fc10.i686 #1 SMP Tue Dec 16 15:12:04 EST 2008 i686 i686 i386 GNU/Linux

Strangely it seems to have no problem associating with the wireless network, still thinks its connected, and gets an IP address... but I can't even ping the default gateway or any other ip address on the network.

I *can* ping its external ip address on wlan0
Comment 3 Dave Russell 2009-01-12 15:54:09 EST
Created attachment 328781 [details]
dmesg output
Comment 4 Dave Russell 2009-01-12 15:54:57 EST
Created attachment 328783 [details]
ifconfig output
Comment 5 Dave Russell 2009-01-12 15:55:32 EST
Created attachment 328784 [details]
iwconfig output
Comment 6 Dave Russell 2009-01-12 15:56:23 EST
Created attachment 328785 [details]
/var/log/messages output
Comment 7 Dave Russell 2009-01-12 16:03:14 EST
Just one more user facing the same issue.

http://fedoraforum.org/forum/showthread.php?t=208382
Comment 8 Ian Weller 2009-01-12 23:35:22 EST
Actually, 2.6.27.9-159.fc10.i686 seems to be working perfectly fine for me.
Comment 9 Ian Weller 2009-01-12 23:44:59 EST
Connection sharing with this adapter now seems to work according to NetworkManager, however a kerneloops.org message box pops up after I do it. This only happened the first time, though.

Will actually test connection sharing tomorrow when I have access to another wireless machine.
Comment 10 Dave Russell 2009-01-13 00:43:01 EST
Glad to hear it. If it ends up working for you best close this bug, and I'll raise a new one.

Note You need to log in before you can comment on or make changes to this bug.