Bug 477096 - up-imapproxy 1.2.7-0.1.rc1.fc10 does not start
up-imapproxy 1.2.7-0.1.rc1.fc10 does not start
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: up-imapproxy (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 21:25 EST by David Rees
Modified: 2009-03-09 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.2.7-0.2.rc1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 01:49:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix imapproxy startup bug (272 bytes, text/plain)
2008-12-18 21:25 EST, David Rees
no flags Details

  None (edit)
Description David Rees 2008-12-18 21:25:49 EST
Created attachment 327404 [details]
Patch to fix imapproxy startup bug

up-imapproxy does not start.

Looking at the init script, it is never called in start!  The attached patch to /etc/init.d/imapproxy fixes it for me.
Comment 1 Rakesh Pandit 2009-01-03 14:29:32 EST
I am not able to reproduce, daemon starts fine for me ?
Comment 2 Rakesh Pandit 2009-01-03 15:01:53 EST
after applying patch I am not able to start my daemon.
Comment 3 manuel wolfshant 2009-01-03 15:36:53 EST
The current startup in devel/cvs (http://cvs.fedoraproject.org/viewvc/rpms/up-imapproxy/devel/imapproxy.init?revision=1.2&view=markup) has:
start() {
	[ -x $exec ] || exit 5
	echo -n $"Starting up-imapproxy daemon: "
	RETVAL=$?
	echo
	[ $RETVAL -eq 0 ] && touch $lockfile
	return $RETVAL
}

And I'd say that indeed there is a missing line before the first RETVAL, that is the line suggested by David which would really start the daemon.

Rakesh, check line 34 of http://cvs.fedoraproject.org/viewvc/rpms/up-imapproxy/devel/imapproxy.init?view=diff&r1=text&tr1=1.1&r2=text&tr2=1.2&diff_format=h and you will notice the problem.
Comment 4 David Rees 2009-02-02 14:23:34 EST
OK, seriously.  Just hit this again on another Fedora 9 server.

It's been 6 weeks since I've opened this bug, I've told you what's wrong with the package.  Someone else has verified the issue and confirmed that my patch is correct.

When is this silly bug going to be fixed?
Comment 5 David Rees 2009-02-02 14:25:05 EST
To be clear - the RPM on Fedora 9 that is also broken is: up-imapproxy-1.2.7-0.1.rc1.fc9

The exact same patch I posted when I opened the bug fixes the issue there, too.
Comment 6 Rakesh Pandit 2009-02-02 22:52:43 EST
I am sorry for not following up .. somehow this issue missed up through my eyes. I will look into it today evening.

Thanks for patience.
Comment 7 Rakesh Pandit 2009-02-03 00:26:19 EST
May you test this on your F9 system before I push it:

http://rakesh.fedorapeople.org/misc/up-imapproxy-1.2.7-0.2.rc1.fc11.i386.rpm

I don't have an F9 system and this is a F9 checkout build on rawhide. Once you confirm I will push.
Comment 8 David Rees 2009-02-03 01:18:32 EST
That won't install on a F9 or F10 system - it requires libcrypto.so.8 and libssl.so.8 which are only available on rawhide, it appears.

What about pushing it to updates-testing first so it can be tested if you don't have a F9/10 build host.  Isn't that what koji is for?
Comment 9 Rakesh Pandit 2009-02-03 01:54:13 EST
SRPM: http://rakesh.fedorapeople.org/misc/up-imapproxy-1.2.7-0.2.rc1.fc11.src.rpm

http://koji.fedoraproject.org/koji/taskinfo?taskID=1100913 

I would like your input before pushing for update testing. Above is a build for F9. May you pull rpm for your machine and test.

As soon as you conform it is working I will push it for update testing.
Comment 10 David Rees 2009-02-03 02:15:18 EST
This RPM has the corrected init script, confirmed that imapproxy starts as expected now!

http://koji.fedoraproject.org/koji/getfile?taskID=1100916&name=up-imapproxy-1.2.7-0.2.rc1.fc9.i386.rpm

Thanks!
Comment 11 Rakesh Pandit 2009-02-03 02:39:15 EST
Thanks for confirming. Thanks will push in update testing in couple of hours.
Comment 12 Fedora Update System 2009-02-04 21:14:02 EST
up-imapproxy-1.2.7-0.2.rc1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update up-imapproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-1278
Comment 13 Fedora Update System 2009-02-04 21:16:35 EST
up-imapproxy-1.2.7-0.2.rc1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update up-imapproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1304
Comment 14 Rakesh Pandit 2009-03-06 01:49:10 EST
Closing ... if problem persist reopen.
Comment 15 Fedora Update System 2009-03-09 18:43:35 EDT
up-imapproxy-1.2.7-0.2.rc1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-03-09 18:51:25 EDT
up-imapproxy-1.2.7-0.2.rc1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.