Bug 477101 - unable to open connection to libvirt management daemon
unable to open connection to libvirt management daemon
Status: CLOSED DUPLICATE of bug 459665
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 22:24 EST by Gary Scarborough
Modified: 2009-02-08 17:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-08 17:16:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Scarborough 2008-12-18 22:24:08 EST
Description of problem:

unable to open connection to libvirt management daemon.  Unable to connect to Fedora 10 install from Fedora 9 machine.  Unable to connect to Fedora 9 machine from Fedora 10.  No connection problem between Fedora 9 machine and CentOS 5.2

Version-Release number of selected component (if applicable):

virtual machine manager 0.6.0
libvirt-0.5.0-1.fc10.i386

How reproducible:

always

Steps to Reproduce:
1. start virtual machine manager
2. add connection
3. Qemu, remote connection over ssh, IP address
  
Actual results:

when connecting from F9 to F10 error box with following message:

Unable to open connection to hypervisor URI 'qemu+ssh://root@10.100.100.89/system':
<class 'libvirt.libvirtError'> Connection reset by peer
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 439, in _open_thread
    None], flags)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 99, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: Connection reset by peer


when connecting from F10 to F9 error:


Unable to open connection to hypervisor URI 'xen+ssh://root@10.100.100.83/':
<class 'libvirt.libvirtError'> Connection reset by peer
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 483, in _open_thread
    None], flags)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 99, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: Connection reset by peer


Expected results:

completed connection


Additional info:
Comment 1 Orion Poplawski 2009-02-06 17:57:23 EST
Seeing the same thing trying to connect to my CentOS 5.2 Xen server:

Unable to open connection to hypervisor URI 'xen+ssh://root@hammer/':
<class 'libvirt.libvirtError'> cannot recv data: Connection reset by peer
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 483, in _open_thread
    None], flags)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 98, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: cannot recv data: Connection reset by peer

libvirt-0.6.0-1.fc10.i386

Problem seems to be related to asking for the root ssh-key pashprase and or root's password on remote, which I'm never prompted for.  strace seems to show a Gtk error for ssh-askpass:

20646 write(2, "\n(ssh-askpass:20646): Gtk-WARNING **: cannot open display: :0.0\n"..., 64) = 64


If I start virt-manager as root rather than as myself and enter root's password, I can connect fine.
Comment 2 Cole Robinson 2009-02-08 17:16:27 EST

*** This bug has been marked as a duplicate of bug 459665 ***

Note You need to log in before you can comment on or make changes to this bug.