Bug 477102 - X server doesn't start with mga matrox graphics driver
X server doesn't start with mga matrox graphics driver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
10
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 22:34 EST by spangle1
Modified: 2009-05-08 16:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.2.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 16:55:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current xorg.conf file (975 bytes, text/plain)
2008-12-25 20:14 EST, spangle1
no flags Details
xorg.conf.new (3.63 KB, text/plain)
2008-12-25 20:15 EST, spangle1
no flags Details
xorg.conf.backup (975 bytes, text/plain)
2008-12-25 20:16 EST, spangle1
no flags Details
xorg.0.log (82.79 KB, text/plain)
2008-12-25 20:17 EST, spangle1
no flags Details
Xorg.0.log.old (82.79 KB, text/plain)
2008-12-25 20:18 EST, spangle1
no flags Details
Xorg.1.log (47.98 KB, text/plain)
2008-12-25 20:18 EST, spangle1
no flags Details
Xorg.1.log.old (179.41 KB, text/plain)
2008-12-25 20:20 EST, spangle1
no flags Details
Current /var/log/Xorg.0.log (30.47 KB, text/plain)
2009-01-22 05:25 EST, spangle1
no flags Details

  None (edit)
Description spangle1 2008-12-18 22:34:26 EST
Description of problem:


Version-Release number of selected component (if applicable):
xorg-x11-drv-mga.i386 1.4.9-1.fc9
kernel-2.6.27.7-134.fc10.i686

How reproducible:


Steps to Reproduce:
1.Install fresh copy of Fedora Core 10 on a machine with a Matrox graphics card
2.Type "startx"
  
Actual results:
The machine goes black screen.  This can be exited from using CTRL+ALT+BACKSPACE; or changing to another tty and then back again, followed by CTRL+C.

Expected results:
X server should start using the mga driver

Additional info:
Comment 1 Matěj Cepl 2008-12-20 19:53:26 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

You can try to use "vesa" driver, so that you have at least some X until we find the true solution for your problem.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 spangle1 2008-12-25 20:14:52 EST
Created attachment 327845 [details]
Current xorg.conf file

Please note that since the bug was first logged, I have done some things that may have changed the xorg.conf file, namely:
1. "system-config-display --set-driver=vesa" from the command line when starting up
2. Putting in a radeon video card (which seems to work worse than the mga on vesa), and further tweaks via X to System:Administration:Display: resolution, colour depth, monitor type and video card.

To mitigate the difficulties that this may cause your diagnosis, I will also attach xorg.conf.new and xorg.conf.backup
Comment 3 spangle1 2008-12-25 20:15:49 EST
Created attachment 327846 [details]
xorg.conf.new

See comments against "current xorg.conf file" attachment
Comment 4 spangle1 2008-12-25 20:16:33 EST
Created attachment 327847 [details]
xorg.conf.backup

See comments against "Current xorg.conf file" attachment
Comment 5 spangle1 2008-12-25 20:17:36 EST
Created attachment 327848 [details]
xorg.0.log
Comment 6 spangle1 2008-12-25 20:18:13 EST
Created attachment 327849 [details]
Xorg.0.log.old
Comment 7 spangle1 2008-12-25 20:18:47 EST
Created attachment 327850 [details]
Xorg.1.log
Comment 8 spangle1 2008-12-25 20:20:28 EST
Created attachment 327851 [details]
Xorg.1.log.old

Please note, I also have an Xorg.setup.log file.  But I'll wait for this to be requested in case I'm accused of spamming :-)
Comment 9 David A. De Graaf 2009-01-01 14:39:18 EST
I have the same or similar problem.  I can no longer start the X server with the Fedora 10 version of xorg-x11-drv-mga-1.4.9-1.fc9.i386 and this video card: 00:11.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W [Millennium II].  I standardly use init level 3 and manually run  startxfce4  after login.

With Fedora 9 this works perfectly,  With Fedora 10 I get these error messages:


(EE) MGA(0): Static buffer allocation failed, not initializing the DRI
(EE) MGA(0): Need at least 9216 kB video memory at this resolution, bit depth
Agent pid 3997

Backtrace:
0: X(xorg_backtrace+0x3b) [0x812bc5b]
1: X(xf86SigHandler+0x51) [0x80bcc81]
2: [0x110400]
3: /usr/lib/libpixman-1.so.0 [0x9e8f2c]
4: /usr/lib/libpixman-1.so.0(pixman_image_composite+0xed) [0x9cceed]
5: /usr/lib/xorg/modules//libfb.so(fbComposite+0x1b2) [0x220692]
6: /usr/lib/xorg/modules//libxaa.so(XAAComposite+0x24f) [0x261bcf]
7: /usr/lib/xorg/modules//libxaa.so [0x27eef1]
8: X [0x816f6fa]
9: X(CompositePicture+0x19a) [0x815818a]
10: X [0x815e055]
11: X [0x815ad75]
12: X(Dispatch+0x34f) [0x8085e9f]
13: X(main+0x47d) [0x806b71d]
14: /lib/libc.so.6(__libc_start_main+0xe5) [0xa356e5]
15: X [0x806ab01]

Fatal server error:
Caught signal 4.  Server aborting

xfce4-session: Fatal IO error 11 (Resource temporarily unavailable) on
X server
:0.0.
xinit:  connection to X server lost.


I briefly get a gray screen, without a cursor, as if X is starting, but then it fails and lists the above error messages on the original console.

The first two lines seem intriguing.  The new mga driver now is unable to allocate a static buffer.  It needs at least 9216 MB of video memory.

This never happened before with F9, same hardware.

I also tried to use the vesa driver as recommended above, but that fails too.

I hope this regression can be fixed soon.  Suddenly not having X is frustrating.
Other info is available if it would help.  Just ask.
Comment 10 Matěj Cepl 2009-01-09 18:17:15 EST
(In reply to comment #9)
> Backtrace:

Lovely, could we get complete /var/log/Xorg.0.log please?
Comment 11 Ingo Hallmackenrheuter 2009-01-17 12:33:14 EST
A possible hint at the root of this problem might be that both the "mga" and the "vesa" driver are compiled for earlier releases of the X.Org server (1.4.99 against 1.5.x) as can be seen in the logfiles.
The same problem appears in recent updates of Fedora Core 9.
The Matrox G550 works fine with openSuSE 11.0 and 11.1, where this driver/server mismatch doesn't show up.
Comment 12 spangle1 2009-01-22 05:25:54 EST
Created attachment 329703 [details]
Current /var/log/Xorg.0.log

I can't remember whether previous xorg.0.log attachments were truncated or not; this one is not -> and as far as my limited understanding allows me to tell, that can be the only benefit of this new Xorg.0.log over the old.   Please note that since the bug report, the machine in question has had a lot of regular use, with the vesa driver enabled - I don't know if that would affect the contents of Xorg.0.log.
Comment 13 Ingo Hallmackenrheuter 2009-04-30 00:52:57 EDT
In a recent update of 'Fedora 10' the 'vesa' driver has finally been replaced by a version (2.2.0-3) that matches the xserver in use (1.5.3). This driver now cooperates flawlessly with the Matrox G550 over VGA-connector up to 1280 x 1024 @ 85 Hz.
Comment 14 David A. De Graaf 2009-05-08 14:25:43 EDT
Hallelujah!  X is back.  The vesa driver does seem to work perfectly.
Thanks for the info, and thanks to whomever fixed it.
Comment 15 Matěj Cepl 2009-05-08 16:55:31 EDT
Closing per comment 14

Note You need to log in before you can comment on or make changes to this bug.