Bug 477178 - Birthday calendar doesn't show contacts birthday
Birthday calendar doesn't show contacts birthday
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 09:03 EST by Jean-Francois Saucier
Modified: 2009-01-05 09:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 10:46:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug output on console (895 bytes, application/octet-stream)
2008-12-19 10:56 EST, Jean-Francois Saucier
no flags Details
evolution debug output (1.37 KB, application/octet-stream)
2008-12-24 15:10 EST, Jean-Francois Saucier
no flags Details
evolution-data-server debug output (4.02 KB, application/octet-stream)
2008-12-24 15:11 EST, Jean-Francois Saucier
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 565361 None None None Never

  None (edit)
Description Jean-Francois Saucier 2008-12-19 09:03:42 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

The birthday calendar in evolution doesn't work as expected. I have entered all my contacts birthday into their profile in evolution Contacts. After that, I have enabled the birthday calendar into the calendar section. At this moment, the calendar was working as it is expected.

But, after a reboot, the birthday don't show up into the calendar view. I have unchecked and rechecked the birthday calendar but it does nothing.

The birthday is set into the profile of the contacts even after a reboot, so it's not this component that is at fault.

If I add new birthday, they show up in the calendar but after a reboot, they are not there anymore.

If I change a contact birthday, it show up in the calendar but after a reboot, they are not there anymore.

Let me know if you need more informations.

Reproducible: Always

Steps to Reproduce:
1.Add birthday information to contact profile
2.Activate birthday calendar
3.Reboot
Actual Results:  
The birthday don't show up into calendar view

Expected Results:  
The birthday show up into calendar view
Comment 1 Milan Crha 2008-12-19 10:37:12 EST
It sounds very similar to the upstream bug [1], but I suspect also other issue than "only" interprocess "data-loss", as I wrote to the upstream bug as a first observation. (There is probably hidden something else, though.)

Anyway, can you try to run Evolution on console and check for messages there? I suspect there will be some like "Unable to query" or very similar. Do you see there such message, please? Also, when you try to move from actual month to the other, and back, will be those birthday events visible after that?

[1] http://bugzilla.gnome.org/show_bug.cgi?id=547949
Comment 2 Jean-Francois Saucier 2008-12-19 10:56:15 EST
You were right, I have some :

(evolution:20016): calendar-gui-WARNING **: gnome-cal.c:910: Could not create the query: Backend is busy

in the console after starting evolution and going to the calendar. I will attach the debug output here.


And no, changing month don't make anything appear, it doesn't change anything.

Thank you
Comment 3 Jean-Francois Saucier 2008-12-19 10:56:32 EST
Created attachment 327454 [details]
Debug output on console
Comment 4 Milan Crha 2008-12-19 11:30:34 EST
Thanks for the response. I believe it's closely related to those "Backend is busy" messages, but I'll check for sure next Monday.

One thing I would like to know: how many contacts do you have in your local address book with filled birthday and/or anniversary dates? As is mentioned in the upstream bug, it also depends on the amount of contacts and sometimes also on the size of that contact, like whether it contains some inline photo or similar.
Comment 5 Jean-Francois Saucier 2008-12-19 11:47:09 EST
I have 164 contacts in my list with ~15 with a birthday already set. I have stopped setting them when I discover the bug.

I have only one contact with inline photo and it's me, set by System->Preferences->Personal->About me tool.

Thank you for your time.
Comment 6 Milan Crha 2008-12-22 10:46:10 EST
I'm not able to reproduce this as often as you, but approximately once in 10 starts it does that for me too (sometimes it's more, sometimes it shows earlier).
I still do not know why it does that. Sometimes it's waiting until the open of the calendar is done, which means also retrieval of the contacts is done, sometimes it just doesn't continue in the opening stage.

I'm moving this upstream [1], even I'll try to figure out what's going on, then I hope someone more experienced will look at the bug and will solve it in the right way. Thanks for you help, Jean-Francois.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=565361
Comment 7 Milan Crha 2008-12-22 16:14:23 EST
It's bad, I really cannot reproduce this reliably. Can you try one thing for me please? I suspect evolution-data-server crashes for you, and even system runs another for you, that new doesn't work as expected. I would like from you to try these steps:
1) close evolution, then run command: evolution --force-shutdown
2) open terminal, run there: /usr/libexec/evolution-data-server-2.24
3) open other terminal, run there: evolution

In running evolution, is it showing there the birthday/anniversary events, when you choose any date where should be some for sure? If they are not there, can you look on the evolution-data-server's console, what is shown there?

Thanks in advance.
Comment 8 Jean-Francois Saucier 2008-12-24 15:10:14 EST
I have done what you have said and I will attach the two debug output from the console.

The birthday didn't show up on a date that I am sure there is one contact but I think there is nothing abnormal in the evolution-data-server output. The same error in the evolution output is there (Backend is busy).

Thank you for your help.
Comment 9 Jean-Francois Saucier 2008-12-24 15:10:41 EST
Created attachment 327825 [details]
evolution debug output
Comment 10 Jean-Francois Saucier 2008-12-24 15:11:01 EST
Created attachment 327826 [details]
evolution-data-server debug output
Comment 11 Milan Crha 2009-01-05 09:31:42 EST
Thanks for your reply. Unfortunately you've right, there is no special error on the consoles, except of that 'unable to query', which is probably because of the 'backend is busy' thing.

I believe, when you run your evolution, and will not see any birthday in the calendar, then attaching gdb to the running evolution-data-server and doing "thread apply all bt" will show one thread with 'book_record_new' function, which means it waits until the book will be opened or until all contacts are received, which is, unfortunately, supposed to be a very quick operation on the local address books.

Let's move any further conversation to the upstream bug, I think it'll be better. (I know, I started it here after closing the bug as 'upstream', I'm sorry.)

Note You need to log in before you can comment on or make changes to this bug.