Bug 477196 - Repackage nutch so it's built from source
Repackage nutch so it's built from source
Status: CLOSED DEFERRED
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: space16
  Show dependency treegraph
 
Reported: 2008-12-19 11:16 EST by John Matthews
Modified: 2011-08-05 06:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-05 06:15:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2008-12-19 11:16:11 EST
Description of problem:

In spacewalk 0.4 we introduced the package nutch.  We are grabbing a nightly built snapshot and using that in the RPM.  This BZ is to remind us we need to change this and fix up the RPM.

We should delete all the built JARS/Classes or obtain a pure source tarball.
Then build the source ourselves and package it up.

Issues will come up because nutch has several dependencies which are not yet in Fedora.  They are included as JARs in the built snapshot.  We'll need to package the dependencies before we can get nutch working from a pure source build.

I created this wiki page to note the work required, it notes what we need and what's currently in Fedora.
https://fedorahosted.org/spacewalk/wiki/GettingPackagesIntoFedora/Nutch
Comment 1 John Matthews 2009-02-20 13:22:46 EST
This work won't be completed for space05, punting to space06
Comment 2 Jan Pazdziora 2010-11-19 11:02:52 EST
Mass-moving to space13.
Comment 3 Jan Pazdziora 2011-02-28 13:41:45 EST
Giving to Tomáš. Is nutch as good and clean as it can get (thus CURRENTRELEASE) or do we need some more work here?
Comment 4 Tomas Lestach 2011-03-01 04:18:26 EST
I've cleaned the nutch spec file for Spacewalk 1.3 and shrunken the final rpm (from the original 70MB) to 22MB.

Build we use is still based on original 1.0 20081201040121nightly build. I tried to use official 0.9, 1.0, 1.1 and 1.2, but none of those worked out of the box.

There're still lib jars included in the package, so the BZ is still valid.
Comment 5 Miroslav Suchý 2011-04-11 03:31:24 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 6 Miroslav Suchý 2011-04-11 03:36:23 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 7 Jan Pazdziora 2011-07-20 07:48:59 EDT
Aligning under space16.
Comment 8 Tomas Lestach 2011-08-05 06:15:58 EDT
I remember I tried to take official nutch versions 1.0,1.1 and 1.2, but none of them worked with our current code just by replacing the current nutch-1.0-0.10.20081201040121nightly. More code changes would be required for the upgrade. However this nightly build is well tested and fulfills our requirements.

It would be nice to have, but currently this is not a priority for Red Hat's Spacewalk developers and will likely not be completed by Red Hat in the next 2
years.

Closing until we're forced to start using official version.

Note You need to log in before you can comment on or make changes to this bug.