Bug 477207 - Evolution crashes while migrating folders to sqlite
Evolution crashes while migrating folders to sqlite
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 12:03 EST by Joshua Rosen
Modified: 2009-10-23 12:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-23 12:16:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2008-12-19 12:03:09 EST
Description of problem: The F10 version of Evolution crashes when it tries migrate folders from the earlier version of Evolution. It looks like it's using an initialized size value when it attempts to allocate memory.


Version-Release number of selected component (if applicable):


How reproducible:100%


Steps to Reproduce:
1. Start Evolution on F10
2.
3.
  
Actual results:
(evolution:22123): camel-WARNING **: Cannot load summary file: '/home/bjrosen/.evolution/mail/local/Chassis.sbd/Agilent.ev-summary': No such file or directory

(evolution:22123): camel-WARNING **: Cannot load summary file: '/home/bjrosen/.evolution/mail/local/Chassis.sbd/HiQ.ev-summary': No such file or directory

GLib-ERROR **: gmem.c:136: failed to allocate 32026589200 bytes
aborting...


Expected results:


Additional info:
Comment 1 Remy Maucherat 2009-01-01 08:48:23 EST
This is being worked on upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=559153
Comment 2 Remy Maucherat 2009-02-19 18:50:38 EST
Still the same issue with 2.24.4-1.fc10.

evolution-shell-Message: Killing old version of evolution-data-server...

(evolution:1219): camel-WARNING **: camel_exception_get_id called with NULL parameter.

(evolution:1219): camel-WARNING **: Cannot load summary file: '/home/remm/.evolution/mail/local/Outbox.ev-summary': No such file or directory

GLib-ERROR **: gmem.c:136: failed to allocate 31400991760 bytes
aborting...
Comment 3 Joe Buck 2009-02-28 04:21:06 EST
This one is rather urgent for me; my wife has a ton of email in Evolution, I upgraded to Fedora 10 not knowing about this bug, and the mail cannot be converted.  I'm surprised it is priority: low.
Comment 4 Devrim GUNDUZ 2009-03-01 13:40:00 EST
I could not move to Fedora-10 because of this bug. I'm really surprised that both Fedora and Gnome folks are not interested in this bug that much. This is a high priority issue that blocks migration from Fedora 9 to Fedora 10.

I have 8+ GB e-mail...

Devrim
Comment 5 Milan Crha 2009-03-02 08:02:05 EST
Actually, there was done some work by upstream people, see [1]. As they do not have some exact test data, it makes things harder.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=559153
Comment 6 Mike Chambers 2009-03-07 10:05:10 EST
What if you go to File/Backup settings and do a backup, then do a fresh install, or at least remove the folders before the upgrade.  Then do a File/Restore settings and see if that works?  You can even copy your folders or back them up just in case so at least you have a copy if it fails.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Matěj Cepl 2009-05-18 08:40:16 EDT
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 8 Matthew Barnes 2009-10-23 12:16:28 EDT
Closing as INSUFFICIENT_DATA due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.