Bug 477233 - Fedora Repository Broken?
Fedora Repository Broken?
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 13:57 EST by Ole
Modified: 2008-12-27 13:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-27 13:29:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ole 2008-12-19 13:57:12 EST
Please see the url pointing to description in the FedoraForum.
Comment 1 Marcela Mašláňová 2008-12-22 03:08:59 EST
Thank you for letting me know, but I don't see this behaviour on my F-10. I have same version of apr-devel, but my perl is perl-5.10.0-51.fc10.x86_64. Could you try with the latest update and let me know? The module Pod::Escapes is subpackage of perl so it should be here. 

Could you please attach output from:
rpm -q perl
rpm -q perl-Pod-Escapes
Comment 2 Ole 2008-12-27 13:29:48 EST
Hi Marcela,

Sorry for the late reply.  Just got back...

The RPM queries look like this:

[ole@ole Documents]$ rpm -q perl
perl-5.10.0-49.fc10.i386
[ole@ole Documents]$ rpm -q perl-Pod-Escapes
perl-Pod-Escapes-1.04-49.fc10.i386
perl-Pod-Escapes-1.04-51.fc10.i386

Hmmm...looks like there's two versions of Pod-Escapes.  If I run yum update I still get the error message.  I'm going to try to remove perl-Pod-Escapes-1.04-51.fc10.i386 and try again.

OK - Now yum update works fine.

I guess the two different versions were confusing yum.  I'm not sure how they both ended up on my system, since it's a brand new install.  Anyways at least it works :-).

I closed the ticket and market it as work for me.

Please let me know if If any more information is needed to isolate how the two different versions were installed.  I think I tried the graphical updater at one point, instead of using yum.  Perhaps there's a bug in it.  

Thanks,
- Ole

Note You need to log in before you can comment on or make changes to this bug.