Bug 477241 - New release of waf
New release of waf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: waf (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 14:38 EST by Fabian Affolter
Modified: 2009-02-11 09:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 09:03:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated libdir patch for 1.5.2 (876 bytes, patch)
2009-01-16 02:56 EST, Peter Gordon
no flags Details | Diff

  None (edit)
Description Fabian Affolter 2008-12-19 14:38:03 EST
There is a new version of waf available.

Current release: 1.5.1
Comment 1 Thomas Moschny 2008-12-19 15:00:44 EST
Yes. I'll update the package for rawhide, but I'm not sure whether we also should update the package in f10.

There's only one other package using waf (midori), we'll have to look whether it can be migrated to 1.5.
Comment 2 Fabian Affolter 2009-01-09 06:14:28 EST
I asked for an update because I was working on another package that use waf.
Comment 3 Peter Gordon 2009-01-16 02:52:48 EST
FYI: 1.5.2 is out.

Thomas: The recent Midori release actually *requires* Waf 1.5 for its option-parsing script code. It includes a copy of a 1.5.2 snapshot within the source tarball, but I feel it would be better if we used a system copy of this for security and bugfix concerns. (With 1.4.4, attempting to run 'waf configure' causes a python traceback.)

I'd greatly appreciate an update to this new Waf version (for F-10 and maybe F-9, too) so that updated Midori packages can also be built.
Comment 4 Peter Gordon 2009-01-16 02:56:01 EST
Created attachment 329170 [details]
Updated libdir patch for 1.5.2

If it helps, here is the updated libdir patch, which I used to build a local RPM of 1.5.2 based on what is currently in Fedora CVS.
Comment 5 Thomas Moschny 2009-01-16 13:04:37 EST
Ok. There's now a 1.5.2 version in rawhide, please test.

I'm still hesitant wrt to upgrading waf in f10 or f9, as this would be an incompatible upgrade, which is strongly discouraged in Fedora.
Comment 6 Michel Alexandre Salim 2009-02-11 09:03:36 EST
If old waf buildscripts no longer work, let's not do this. There have been cases (Django, unison) where incompatible upgrades are done and receive lots of complaints.

Trying to remember what happened to cmake -- I believe the maintainer only upgraded to 2.6 in what was then Rawhide, leaving the stable repos with 2.4

Note You need to log in before you can comment on or make changes to this bug.