Bug 477284 - Cobbler does not add repo properly on installed system
Cobbler does not add repo properly on installed system
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 20:18 EST by Dennis Jacobfeuerborn
Modified: 2008-12-22 10:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 10:51:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2008-12-19 20:18:10 EST
I added the EPEL repository to cobbler using the following command-line:

cobbler repo add --name=EPEL-5-i386 --mirror=http://download.fedora.redhat.com/pub/epel/5/i386/ --mirror-locally=0

After that I selected the repo under "Yum Repos" in a profile, modified the kickstart template to add some packages ("puppet" among others) and used that profile to install a System (CentOS-5.2).

After the installation the puppet package is installed showing that the repo worked properly during the installation but /etc/yum.repos.d/cobbler-config.repo contains this line:

# error: could not read repo source: /var/www/cobbler/repo_mirror/EPEL-5-i386/config.repo

The directory "/var/www/cobbler/repo_mirror" is empty on the cobbler server (likely because I used the "--mirror-locally=0" option when adding the repo).
Cobbler should instead append the repo data used during the installation to the config file.
Comment 1 Michael DeHaan 2008-12-21 14:24:16 EST
It appears you still need to run "cobbler reposync" to generate the configuration files this repo will use, even though it is local.

If you haven't done this and still have this problem, let me know.
Comment 2 Michael DeHaan 2008-12-22 10:51:03 EST
I've confirmed that is in fact how it works, I've opened a RFE in Trac to streamline this for a future release:

https://fedorahosted.org/cobbler/ticket/337#preview

Note You need to log in before you can comment on or make changes to this bug.