Bug 477314 - evolution does not show changed maildirs
evolution does not show changed maildirs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 07:54 EST by Christoph Höger
Modified: 2009-06-28 21:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 21:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 587259 None None None Never

  None (edit)
Description Christoph Höger 2008-12-20 07:54:06 EST
Description of problem:
I have offlineimap setup to sync a imap account with a local maildir, evolution is setup to read that maildir. So the following happens quite often: I start offlineimap which changes the maildir content, then I start evolution to read my mail. But after the first startup, I can only see the count of new messages in the folder name (in brackets, e.g. 23 unread mails). In the folder view only the messages from the last run are displayed. "Refresh" has no effect on that.
When I close evolution, after a while the new messages are shown just before evolutions windows disappear. After the next start, sometimes the folder view is completely corrupted (showing only some messages) or ok. After the third startup all works fine as expected.

Version-Release number of selected component (if applicable):
evolution-2.24.2-2.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. login, change maildir content (e.g. by running offlineimap)
2. start evolution
  
Actual results:
no new messages displayed

Expected results:
They should be visible ;)

Additional info:
I am quite sure, that this is not caused by offlineimap, on f9 running the very same version of offlineimap all works fine.
Comment 1 Mike Chambers 2009-03-07 09:23:56 EST
Are you still experiencing this problem?  If so, what versions of evo are you now using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 James Davidson 2009-03-09 00:30:24 EDT
I still see the problem with the following evolution packages installed:

evolution-2.24.5-1.fc10.i386
evolution-data-server-2.24.5-1.fc10.i386
evolution-help-2.24.5-1.fc10.i386
evolution-perl-2.24.5-1.fc10.i386
evolution-webcal-2.23.91-1.fc10.i386
Comment 3 Matthew Barnes 2009-06-28 21:52:18 EDT
Moving this upstream for better visibility.
Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=587259

Note You need to log in before you can comment on or make changes to this bug.