Bug 477322 - Intel 4965 wlan stops working until needs reboot
Intel 4965 wlan stops working until needs reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iwl4965-firmware (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 10:17 EST by Boris Devouge
Modified: 2009-01-12 12:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 12:24:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Devouge 2008-12-20 10:17:02 EST
Description of problem:

I am filing this under the firmware, but not sure if related to module/kernel so I apologize in advance if this is wrong.

This issue seems to be reported upstream in http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1855

At unpredictable intervals, the iwlagn drivers fails, all wireless transmissions fail, and the only way to recover the wireless is a clean reboot of the machine.

This is on Lenovo X300 running Fedora 10 i386.


Version-Release number of selected component (if applicable):

kernel-PAE-2.6.27.7-134.fc10.i686
iwl4965-firmware-228.57.2.21-3.noarch

iwlagn:
alias:          iwl4965
license:        GPL
author:         Copyright(c) 2003-2008 Intel Corporation
version:        1.3.27kds
description:    Intel(R) Wireless WiFi Link AGN driver for Linux
firmware:       iwlwifi-4965-2.ucode

How reproducible:

Seems this affects the iwl4965 hardware. Simply run the machine, and watch the wireless fail (2/3 minutes to sometimes a week between failures).
  
Actual results:

Wireless suddenly fails and a reboot is needed to restore connectivity.

Expected results:

No wireless failure

Additional info:

Logs show the following:

Dec 20 13:44:45 speedy kernel: iwlagn: HARDWARE GONE?? INTA == 0x000000000000000000000000000000000000000000000000000000000000000000000000ffffffff

I have added a 'me too' in what seems to be the upstream bug.
Comment 1 Nicolas Chauvet (kwizart) 2009-01-12 12:24:20 EST
The last firmware for iwl4965 is 
iwl4965-firmware-228.57.2.23 and was in the stable repos the days before this bug report.

Note You need to log in before you can comment on or make changes to this bug.