Bug 477327 - [PATCH] Command line of 255 characters is sometimes not long enough
[PATCH] Command line of 255 characters is sometimes not long enough
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2008-12-20 11:23 EST by Lubomir Rintel
Modified: 2009-01-11 08:17 EST (History)
1 user (show)

See Also:
Fixed In Version: grub-0_97-37_fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-11 08:17:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Support longer command lines in GRUB (3.06 KB, text/plain)
2008-12-20 11:23 EST, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2008-12-20 11:23:10 EST
Created attachment 327541 [details]
Support longer command lines in GRUB

preupgrade did not work for me, since it generated a kernel command line that included an url to install.img on a mirror, which was too long to fit in 256 characters.

Current kernels support command line of up to 2047 characters, which the attached patch adds support for (at least on i386 w/ PC BIOS, no idea about EFI).
Comment 1 Lubomir Rintel 2009-01-02 07:31:15 EST
Ping.
Comment 2 Lubomir Rintel 2009-01-11 08:17:00 EST
Fixed in grub-0_97-37_fc11

Note You need to log in before you can comment on or make changes to this bug.