Bug 477328 - [PATCH] Ext2 is not Ext3
[PATCH] Ext2 is not Ext3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2008-12-20 11:45 EST by Lubomir Rintel
Modified: 2009-01-05 12:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 12:43:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Try to mount filesystems as ext3 (2.69 KB, patch)
2008-12-20 11:45 EST, Lubomir Rintel
no flags Details | Diff

  None (edit)
Description Lubomir Rintel 2008-12-20 11:45:30 EST
Created attachment 327543 [details]
Try to mount filesystems as ext3

Preupgrade failed for me, since anaconda couldn't read the kickstart file from my /boot partition. It turned out that it fails an attempt to mount -t ext2 /boot due to unsupported optional features. If I remember correctly, it did not fail all of my repeated attempts, but in the end I couldn't get the F-10 kernel mount my ext3 /boot with -t ext2. I had to work around by removing the journal with tune2fs -o ^has_journal, after which the upgrade completed successfully.

Attached patch tries to address the problem.
Comment 1 Jeremy Katz 2008-12-21 19:39:05 EST
We should probably do better and switch to just doing mount -t auto at this point as we're using real mount(8) as opposed to calling mount(2) ourselves
Comment 2 Lubomir Rintel 2008-12-23 17:06:32 EST
Yes, that certainly makes sense.
Comment 3 Chris Lumens 2009-01-05 12:43:28 EST
This will be fixed in the next build of anaconda.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.