Bug 477352 - [i18n-fr] Wrong translations about masculine/feminine forms
[i18n-fr] Wrong translations about masculine/feminine forms
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 16:24 EST by Milan Bouchet-Valat
Modified: 2009-09-21 18:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-29 17:38:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bouchet-Valat 2008-12-20 16:24:26 EST
This is about French localisation of system-config-printer.

Several sentences have been poorly translated because the translator did not check whether he was dealing with masculine or feminine nouns. Thus, he translated "Disconnected?" to "Déconnecté(e) ?", which is ridiculous since the user can see we're talking about a printer (feminine in French). This is ugly since it's a notification showing up on the desktop.

You can get the three bad strings here:
https://translations.launchpad.net/ubuntu/intrepid/+source/system-config-printer/+pots/system-config-printer/fr/+translate?batch=10&show=all&search=connect%C3%A9(e)

It's in Ubuntu's Launchpad, sorry, but these are strings #23, #85 and #389.

Thanks!
Comment 1 Martin-Gomez Pablo 2008-12-27 06:27:48 EST
Thanks for point out this. I fixed it in the branch "master" of "system-config-printer". Tell me if it works or not.
Comment 2 Milan Bouchet-Valat 2008-12-27 09:35:51 EST
Thanks! But I've no way to check since I'm not using Fedora. I'll have to wait the sync with Ubuntu and an update, which may take a long time...

If somebody has free time, it could be nice to check all the translations in s-c-p, there seems to be several approximations.
Comment 3 Thomas Canniot 2008-12-28 04:43:09 EST
(In reply to comment #2)
> If somebody has free time, it could be nice to check all the translations in
> s-c-p, there seems to be several approximations.

Could you please detail those approximations ? This would save us lots of time... Fedora French Translation team is very small :(

Thanks
Comment 4 Milan Bouchet-Valat 2008-12-28 05:18:53 EST
For example, in the tool that allows you to choose your default printer, the buttons have for label: "Utiliser la valeur par défaut" et "Définir la valeur par défaut", which is obviously confusing when you don't really know what this is about. The first could be "Définir comme valeur par défaut", at least - but the English version must be confusing too.

I forgot this one too in the report: when you start s-c-p, the status bar tels "Connecté(e) à localhost". It seems that the guy who did the work had no time to check... :-p

In Fichier->Paramètres and 'Advanced', you get a window titled "Paramètres serveur avancés", which should be "Paramètres avancés du serveur". In this window, under "Parcourir les serveurs", the second sentence "Spécifiez les serveurs d'impression..." should be rephrased to something like "Spécifiez ici les serveurs d'impression à qui il faut, au contraire, demander régulièrement leurs files d'attentes." When you click on "Ajouter", the text "Saisir l'adresse IP" could be improved to "Saisissez l'adresse IP" (just like in the file chooser).

In the printer properties dialog, under "Options des tâches", "Spécifier..." should be an imperative form, just like it is elsewhere: "Spécifiez les options par défaut..."

I know it's difficult in little team like Fedora's or Ubuntu's to do perfect translations...
Comment 5 Tim Waugh 2008-12-28 14:10:18 EST
(In reply to comment #1)
> Thanks for point out this. I fixed it in the branch "master" of
> "system-config-printer". Tell me if it works or not.

Please note: the "master" branch is for what will become system-config-printer 1.2.  The current stable branches are 1.0.x and 1.1.x.  Fedora 10 is using 1.0.x.
Comment 6 Martin-Gomez Pablo 2008-12-29 07:04:30 EST
(In reply to comment #5)
> Please note: the "master" branch is for what will become system-config-printer
> 1.2.  The current stable branches are 1.0.x and 1.1.x.  Fedora 10 is using
> 1.0.x.

Thanks for the information. :-)

 
Need Real Name> It seems that Ubuntu use a 0.7.x version, as the 1.0.x version do not have this approximations (except for "Définir comme valeur par défaut" changed in the 1.0 branch). So if you want I'll could made this changes to the 0.7.x branch, but I'm not sure that will be a update or a rebuild. So better, open a RFE (Request for Enhancement) bug against s-c-p in Ubuntu to have a 1.0.x version (maybe for 9.04)
Comment 7 Milan Bouchet-Valat 2008-12-29 12:04:19 EST
OK, thanks, but I've already fixed the most problematic strings, they'll automatically packaged in released distributions. Others can wait, nothing is really critical. And I'll let 1.0 get into Ubuntu via the normal process, I'm sure we'll want it anyway, there are reasons for that other than translations. ;-)

PS: I had not seen that my pseudo is Need Real Name - strange default name, really!
Comment 8 Martin-Gomez Pablo 2008-12-29 17:38:41 EST
Ok, so thanks for notify the upstream translation :-) I finally close this bug, as  everything seems to be fixed

Note You need to log in before you can comment on or make changes to this bug.