Bug 47739 - DNS works locally but will not serve clients
DNS works locally but will not serve clients
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 14:29 EDT by Rob Brothers
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-08 01:48:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Brothers 2001-07-06 14:29:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
I have installed and configured bind as a caching only server on my LAN.
named starts automatically and I am able to use the dig and nslookup
commands locally to resolve names. The firewall is disabled. When I point
other machines on the LAN to this one for DNS resolution, they are not able
to see the web.  service named status returns a connection refused

How reproducible:
Always

Steps to Reproduce:
1.make sure named is running		
2.configure client pc with dns ip address
3.browse web
	

Actual Results:  not able to find page

Expected Results:  www.redhat.com should appear

Additional info:
Comment 1 Michael Schwendt 2001-07-08 01:48:14 EDT
First of all, "service named status" does only work if you have rndc enabled.
See "man rndc" and the Bind v9 ARM in /usr/share/doc/bind-9.1.0.

Secondly, upon startup, bind logs to /var/log/messages on which interfaces it is
listening. I don't think bind is restricted by default and listens to all
interfaces. But you can have an influence on which interfaces it listens to by
adding a section like this

    listen-on {
        127.0.0.1;
        192.168.1/24;
    };
to /etc/named.conf.
Comment 2 Bernhard Rosenkraenzer 2001-07-10 10:09:01 EDT
I can't reproduce any of this.
Chances are you either misconfigured the listen-on interfaces or you 
misconfigured the forwarders.

Make sure /etc/named.conf contains a forwarders statement and either doesn't 
contain listen-on statements at all, or explicitly lists the interfaces you 
want to bind to.

Also, make sure the clients are configured correctly.

Note You need to log in before you can comment on or make changes to this bug.