This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 477406 - kdeedu: Please convert to new font packaging guidelines
kdeedu: Please convert to new font packaging guidelines
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdeedu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On: 481484 481501
Blocks: F11-new-font-rules
  Show dependency treegraph
 
Reported: 2008-12-20 19:30 EST by Nicolas Mailhot
Modified: 2009-02-14 17:52 EST (History)
8 users (show)

See Also:
Fixed In Version: 4.2.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-14 17:52:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-12-20 19:30:41 EST
This bug has been filed because we've detected your package includes one or several font files:                                                                                                                                                             repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq                                                                                                                                                             Unfortunately the script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.                                                                                                                                                              Otherwise, you should know that:                                                                                                                                                              - Fedora guidelines demand the packaging of fonts in a separate package or subpackage: http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages                                                                                - our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package. http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18) http://fedoraproject.org/wiki/Fedora_fonts_policy_package http://fedoraproject.org/wiki/Simple_fonts_spec_template http://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts                                                                                                                                                              Please make your package conform to the current guidelines in rawhide.                                                                                                                                                             If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.                                                                                                                                                              It is preferred to make a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family                                                                                                                                                              The new templates should make the creation of font subpackages easy and safe.                                                                                                                                                              The following packages have already been converted and can serve as examples: - andika-fonts - apanov-heuristica-fonts - bitstream-vera-fonts - charis-fonts - dejavu-fonts - ecolier-court-fonts - edrip-fonts - gfs-ambrosia-fonts - gfs-artemisia-fonts - gfs-baskerville-fonts - gfs-bodoni-classic-fonts - gfs-bodoni-fonts - gfs-complutum-fonts - gfs-didot-classic-fonts - gfs-didot-fonts - gfs-eustace-fonts - gfs-fleischman-fonts - gfs-garaldus-fonts - gfs-gazis-fonts - gfs-jackson-fonts - gfs-neohellenic-fonts - gfs-nicefore-fonts - gfs-olga-fonts - gfs-porson-fonts - gfs-solomos-fonts - gfs-theokritos-fonts - stix-fonts - yanone-kaffeesatz-fonts                                                                                                                                                           If you have any remaining questions about the new guidelines please ask them on fedora-fonts-list at redhat.com
Comment 1 Nicolas Mailhot 2008-12-20 19:55:58 EST
[Since the bot made a mess of the text here it is again in properly indented form.]

This bug has been filed because we've detected your package includes one or several font files:

repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq

Unfortunately this script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.

Otherwise, you should know that:

— Fedora guidelines demand the packaging of fonts in a separate package (or subpackage):
http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages

— our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package:
  – http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18)
  – http://fedoraproject.org/wiki/Fedora_fonts_policy_packagehttp://fedoraproject.org/wiki/Simple_fonts_spec_templatehttp://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts

Please make your package conform to the current guidelines in rawhide (you can use the fontpackages package in F9 or F10 to test, but only submit changes to rawhide please).

If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.

It is preferred to create a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on:
http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family

The new templates should make the creation of font subpackages easy and safe.

The following packages have already been converted by their packager and can serve as examples:
❄ andika-fonts
❄ apanov-heuristica-fonts
❄ bitstream-vera-fonts
❄ charis-fonts
❄ dejavu-fonts
❄ ecolier-court-fonts
❄ edrip-fonts
❄ gfs-ambrosia-fonts
❄ gfs-artemisia-fonts
❄ gfs-baskerville-fonts
❄ gfs-bodoni-classic-fonts
❄ gfs-bodoni-fonts
❄ gfs-complutum-fonts
❄ gfs-didot-classic-fonts
❄ gfs-didot-fonts
❄ gfs-eustace-fonts
❄ gfs-fleischman-fonts
❄ gfs-garaldus-fonts
❄ gfs-gazis-fonts
❄ gfs-jackson-fonts
❄ gfs-neohellenic-fonts
❄ gfs-nicefore-fonts
❄ gfs-olga-fonts
❄ gfs-porson-fonts
❄ gfs-solomos-fonts
❄ gfs-theokritos-fonts
❄ stix-fonts
❄ yanone-kaffeesatz-fonts

If you have any remaining questions about the new guidelines please ask them on:
fedora-fonts-list at redhat.com
Comment 2 Rex Dieter 2008-12-21 16:22:11 EST
$ rpm -ql kdeedu | grep ttf
/usr/share/kde4/apps/blinken/fonts/steve.ttf
/usr/share/kde4/apps/khangman/fonts/Domestic_Manners.ttf
/usr/share/kde4/apps/khangman/fonts/Dustismo_Roman.ttf

Per Kevin's investigation, looks like these use sjfonts, dustismo-fonts, respectively, per
https://fedoraproject.org/wiki/Steve_Hand_fonts
https://fedoraproject.org/wiki/Dustimo_fonts
 other links: 
   http://www.dustismo.com/ (down?)
   http://ospublish.constantvzw.org
Comment 3 Nicolas Mailhot 2008-12-21 16:59:38 EST
Those are all in the Fedora wishlist. Clean packages would be appreciated (and would made the fonts available to all the fontconfig apps)
Comment 4 Kevin Kofler 2008-12-22 02:59:27 EST
+1, understood and agreed.
I wasn't aware of these being bundled at all before your audit.
Comment 5 Sven Lankes 2008-12-30 21:27:30 EST
Domestic_manners is currently not on the wishlist - it is here 
http://www.urbanfonts.com/fonts/Domestic_Manners.htm
Comment 6 Kevin Kofler 2008-12-30 21:38:27 EST
It's from the same author as Dustismo Roman. There are some more of his fonts. Unfortunately, the original site (www.dustismo.com) is no longer up, so we have to trust third-party sites to tell the truth about licensing, e.g.:
http://patch-tracking.debian.net/patch/debianonly/view/ttf-dustin/20030517-4
Comment 7 Kevin Kofler 2008-12-30 21:44:41 EST
See also http://www.1001fonts.com/member_profile.html?author_id=1719 - the ZIP files in there have a license.txt saying they're GPLv2+ (which matches the information from the Debian package).
Comment 8 Nicolas Mailhot 2009-01-04 05:59:49 EST
(In reply to comment #5)
> Domestic_manners is currently not on the wishlist - it is here 
> http://www.urbanfonts.com/fonts/Domestic_Manners.htm

So just add a new entry in the wishlist, and package the font :p
Comment 9 Nicolas Mailhot 2009-01-11 10:19:39 EST
To help packagers manage the transition to the new guidelines, we've published the following FAQ

http://fedoraproject.org/wiki/Shipping_fonts_in_other_packages_(FAQ)
Comment 10 Nicolas Mailhot 2009-01-14 13:37:11 EST
FPC approved those two additional guidelines recently, please take them into account if you need to create or update a fonts package or subpackage:

– 2009-01-14: naming
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_naming_%282009-01-13%29

— 2009-01-06: exact splitting rules
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_splitting_rules_%282008-12-21%29

(packagers that can drop font files and just depend on an existing font package are not impacted)
Comment 11 Sven Lankes 2009-01-25 11:35:50 EST
kdeedu / khangman from kde 4.2 doesn't seem to ship dustismo anymore - only SteveHand (called steve.ttf in kdeedu) and Domestic_Manners.ttf (which still needs to be packaged).
Comment 12 Kevin Kofler 2009-01-25 11:39:21 EST
There's no copy of Dustismo Roman in our 4.2.0 packages because we're using the copy you packaged and removing the shipped one.
Comment 13 Kevin Kofler 2009-02-06 08:51:11 EST
We're now using the system copies of the dustin-*-fonts.

What's left to look into is SteveHand alias steve.ttf. There's now a system sj-stevehand-fonts (thanks Sven!). Rex, can you please check how to get Blinken to use the system copy?

Note You need to log in before you can comment on or make changes to this bug.