Bug 477408 - [khmeros-fonts] Please convert to new font packaging guidelines
[khmeros-fonts] Please convert to new font packaging guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: khmeros-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Nowak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11-new-font-rules 477427
  Show dependency treegraph
 
Reported: 2008-12-20 19:31 EST by Nicolas Mailhot
Modified: 2013-03-07 21:05 EST (History)
4 users (show)

See Also:
Fixed In Version: khmeros-fonts-5.0-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 05:59:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-12-20 19:31:02 EST
This bug has been filed because we've detected your package includes one or several font files:                                                                                                                                                             repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq                                                                                                                                                             Unfortunately the script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.                                                                                                                                                              Otherwise, you should know that:                                                                                                                                                              - Fedora guidelines demand the packaging of fonts in a separate package or subpackage: http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages                                                                                - our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package. http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18) http://fedoraproject.org/wiki/Fedora_fonts_policy_package http://fedoraproject.org/wiki/Simple_fonts_spec_template http://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts                                                                                                                                                              Please make your package conform to the current guidelines in rawhide.                                                                                                                                                             If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.                                                                                                                                                              It is preferred to make a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family                                                                                                                                                              The new templates should make the creation of font subpackages easy and safe.                                                                                                                                                              The following packages have already been converted and can serve as examples: - andika-fonts - apanov-heuristica-fonts - bitstream-vera-fonts - charis-fonts - dejavu-fonts - ecolier-court-fonts - edrip-fonts - gfs-ambrosia-fonts - gfs-artemisia-fonts - gfs-baskerville-fonts - gfs-bodoni-classic-fonts - gfs-bodoni-fonts - gfs-complutum-fonts - gfs-didot-classic-fonts - gfs-didot-fonts - gfs-eustace-fonts - gfs-fleischman-fonts - gfs-garaldus-fonts - gfs-gazis-fonts - gfs-jackson-fonts - gfs-neohellenic-fonts - gfs-nicefore-fonts - gfs-olga-fonts - gfs-porson-fonts - gfs-solomos-fonts - gfs-theokritos-fonts - stix-fonts - yanone-kaffeesatz-fonts                                                                                                                                                           If you have any remaining questions about the new guidelines please ask them on fedora-fonts-list at redhat.com
Comment 1 Nicolas Mailhot 2008-12-20 19:56:01 EST
[Since the bot made a mess of the text here it is again in properly indented form.]

This bug has been filed because we've detected your package includes one or several font files:

repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq

Unfortunately this script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.

Otherwise, you should know that:

— Fedora guidelines demand the packaging of fonts in a separate package (or subpackage):
http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages

— our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package:
  – http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18)
  – http://fedoraproject.org/wiki/Fedora_fonts_policy_packagehttp://fedoraproject.org/wiki/Simple_fonts_spec_templatehttp://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts

Please make your package conform to the current guidelines in rawhide (you can use the fontpackages package in F9 or F10 to test, but only submit changes to rawhide please).

If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.

It is preferred to create a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on:
http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family

The new templates should make the creation of font subpackages easy and safe.

The following packages have already been converted by their packager and can serve as examples:
❄ andika-fonts
❄ apanov-heuristica-fonts
❄ bitstream-vera-fonts
❄ charis-fonts
❄ dejavu-fonts
❄ ecolier-court-fonts
❄ edrip-fonts
❄ gfs-ambrosia-fonts
❄ gfs-artemisia-fonts
❄ gfs-baskerville-fonts
❄ gfs-bodoni-classic-fonts
❄ gfs-bodoni-fonts
❄ gfs-complutum-fonts
❄ gfs-didot-classic-fonts
❄ gfs-didot-fonts
❄ gfs-eustace-fonts
❄ gfs-fleischman-fonts
❄ gfs-garaldus-fonts
❄ gfs-gazis-fonts
❄ gfs-jackson-fonts
❄ gfs-neohellenic-fonts
❄ gfs-nicefore-fonts
❄ gfs-olga-fonts
❄ gfs-porson-fonts
❄ gfs-solomos-fonts
❄ gfs-theokritos-fonts
❄ stix-fonts
❄ yanone-kaffeesatz-fonts

If you have any remaining questions about the new guidelines please ask them on:
fedora-fonts-list at redhat.com
Comment 2 Nicolas Mailhot 2009-01-11 10:19:42 EST
To help packagers manage the transition to the new guidelines, we've published the following FAQ

http://fedoraproject.org/wiki/Shipping_fonts_in_other_packages_(FAQ)
Comment 3 Nicolas Mailhot 2009-01-14 13:37:16 EST
FPC approved those two additional guidelines recently, please take them into account if you need to create or update a fonts package or subpackage:

– 2009-01-14: naming
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_naming_%282009-01-13%29

— 2009-01-06: exact splitting rules
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_splitting_rules_%282008-12-21%29

(packagers that can drop font files and just depend on an existing font package are not impacted)
Comment 4 Jon Ciesla 2009-01-23 11:16:56 EST
Hi, I'm the moodle maintainer, and I need khmeros-fonts to comply before I can bring moodle into compliance so I thought I'd offer suggestions or assistance.  I could:

1. Offer my observations on what needs to be done.

2. Provide a patched spec.

3. Change, commit and build the thing myself (after your review if you like, or course), as I'm a provenpackager member.

4. Butt out. :)


Any of these sound appealing?
Comment 5 Michal Nowak 2009-01-24 07:44:22 EST
Hi Jon, thanks for interest in khmeros-fonts pkg!

Please see my today's cvs commit to khmeros-fonts target. I pulled there what I guess is something near to F-11 compliance. But there are still some issues:

- Obsoletes/Provides are not finished. In the 'base' pkg you can see my proposal, which is somewhat bogus :). I believe there's on Fedora wiki some guide on O/P labels but I failed to find it.

- The -commons sub-package seems to be useless, nothing but *.ttf's are shipped.

- Fontconfig support is missing, but not a hard requirement.

Eventually, you'll find other problems - please, share them, then we'll what can be done :).
Comment 6 Nicolas Mailhot 2009-01-25 06:13:54 EST
(In reply to comment #5)

> - Obsoletes/Provides are not finished. In the 'base' pkg you can see my
> proposal, which is somewhat bogus :). I believe there's on Fedora wiki some
> guide on O/P labels but I failed to find it.

Provides for the old font names are probably unecessary

If each new font subpackage corresponds exactly to one or several old (sub)packages, you only need to
Orsolete: oldpackagename < thisversion-thisrelease

If the mapping is less obvious look at the compat packages in dejavu for example

> - The -commons sub-package seems to be useless, nothing but *.ttf's are
> shipped.

http://fedoraproject.org/wiki/Shipping_fonts_in_Fedora_(FAQ)#What.27s_the_point_of_the_common_subpackage.3F

> - Fontconfig support is missing, but not a hard requirement.

It's not but it help browsers at least. Upstream should be able to give you the information needed to fill them in (to what CSS category each font belongs, etc)
 
> Eventually, you'll find other problems - please, share them, then we'll what
> can be done :).

Don't hesitate to ping me on irc or on the fonts list if you have specific problems. I'll probably eventually review the changes in this package as I did with others, but I have a long review queue nowadays.
Comment 8 Michal Nowak 2009-01-25 09:18:18 EST
(In reply to comment #7)
> Provides for the old font names are probably unecessary

rpmlint complains but thanks to the FAQ I understand it more clearly.


(In reply to comment #6)

> Orsolete: oldpackagename < thisversion-thisrelease

Done.

> http://fedoraproject.org/wiki/Shipping_fonts_in_Fedora_(FAQ)#What.27s_the_point_of_the_common_subpackage.3F

:). Thanks.

> Don't hesitate to ping me on irc or on the fonts list if you have specific
> problems. I'll probably eventually review the changes in this package as I did
> with others, but I have a long review queue nowadays.

Thanks again Nicolas.
--

Jon, if you have time, have a look into the cvs.
Comment 9 Jon Ciesla 2009-01-26 12:41:52 EST
Looks OK to me.  Once it's built, I'll finish fixing moodle.
Comment 10 Michal Nowak 2009-01-26 16:02:11 EST
5.0-5 just built in Rawhide. Let me know if there are ongoing issues.

Note You need to log in before you can comment on or make changes to this bug.