Bug 477433 - Please convert to new font packaging guidelines
Please convert to new font packaging guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11-new-font-rules
  Show dependency treegraph
 
Reported: 2008-12-20 19:35 EST by Nicolas Mailhot
Modified: 2009-01-12 18:43 EST (History)
2 users (show)

See Also:
Fixed In Version: nted-1.4.17-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 08:57:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-12-20 19:35:21 EST
This bug has been filed because we've detected your package includes one or several font files:                                                                                                                                                             repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq                                                                                                                                                             Unfortunately the script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.                                                                                                                                                              Otherwise, you should know that:                                                                                                                                                              - Fedora guidelines demand the packaging of fonts in a separate package or subpackage: http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages                                                                                - our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package. http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18) http://fedoraproject.org/wiki/Fedora_fonts_policy_package http://fedoraproject.org/wiki/Simple_fonts_spec_template http://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts                                                                                                                                                              Please make your package conform to the current guidelines in rawhide.                                                                                                                                                             If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.                                                                                                                                                              It is preferred to make a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family                                                                                                                                                              The new templates should make the creation of font subpackages easy and safe.                                                                                                                                                              The following packages have already been converted and can serve as examples: - andika-fonts - apanov-heuristica-fonts - bitstream-vera-fonts - charis-fonts - dejavu-fonts - ecolier-court-fonts - edrip-fonts - gfs-ambrosia-fonts - gfs-artemisia-fonts - gfs-baskerville-fonts - gfs-bodoni-classic-fonts - gfs-bodoni-fonts - gfs-complutum-fonts - gfs-didot-classic-fonts - gfs-didot-fonts - gfs-eustace-fonts - gfs-fleischman-fonts - gfs-garaldus-fonts - gfs-gazis-fonts - gfs-jackson-fonts - gfs-neohellenic-fonts - gfs-nicefore-fonts - gfs-olga-fonts - gfs-porson-fonts - gfs-solomos-fonts - gfs-theokritos-fonts - stix-fonts - yanone-kaffeesatz-fonts                                                                                                                                                           If you have any remaining questions about the new guidelines please ask them on fedora-fonts-list at redhat.com
Comment 1 Nicolas Mailhot 2008-12-20 19:56:38 EST
[Since the bot made a mess of the text here it is again in properly indented form.]

This bug has been filed because we've detected your package includes one or several font files:

repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq

Unfortunately this script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.

Otherwise, you should know that:

— Fedora guidelines demand the packaging of fonts in a separate package (or subpackage):
http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages

— our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package:
  – http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18)
  – http://fedoraproject.org/wiki/Fedora_fonts_policy_packagehttp://fedoraproject.org/wiki/Simple_fonts_spec_templatehttp://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts

Please make your package conform to the current guidelines in rawhide (you can use the fontpackages package in F9 or F10 to test, but only submit changes to rawhide please).

If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.

It is preferred to create a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on:
http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family

The new templates should make the creation of font subpackages easy and safe.

The following packages have already been converted by their packager and can serve as examples:
❄ andika-fonts
❄ apanov-heuristica-fonts
❄ bitstream-vera-fonts
❄ charis-fonts
❄ dejavu-fonts
❄ ecolier-court-fonts
❄ edrip-fonts
❄ gfs-ambrosia-fonts
❄ gfs-artemisia-fonts
❄ gfs-baskerville-fonts
❄ gfs-bodoni-classic-fonts
❄ gfs-bodoni-fonts
❄ gfs-complutum-fonts
❄ gfs-didot-classic-fonts
❄ gfs-didot-fonts
❄ gfs-eustace-fonts
❄ gfs-fleischman-fonts
❄ gfs-garaldus-fonts
❄ gfs-gazis-fonts
❄ gfs-jackson-fonts
❄ gfs-neohellenic-fonts
❄ gfs-nicefore-fonts
❄ gfs-olga-fonts
❄ gfs-porson-fonts
❄ gfs-solomos-fonts
❄ gfs-theokritos-fonts
❄ stix-fonts
❄ yanone-kaffeesatz-fonts

If you have any remaining questions about the new guidelines please ask them on:
fedora-fonts-list at redhat.com
Comment 2 Hans Ulrich Niedermann 2008-12-21 06:26:03 EST
I'll take a look at this and try to find out what I am actually supposed to change in terminus-font.

Looks like this is going to take several hours, so it won't happen within the next few days.
Comment 3 Nicolas Mailhot 2008-12-21 06:48:37 EST
The target of this bug is first F11 alpha. Take your time to do things properly and ask on the list if you need more info
Comment 4 Nicolas Mailhot 2009-01-11 10:20:02 EST
To help packagers manage the transition to the new guidelines, we've published the following FAQ

http://fedoraproject.org/wiki/Shipping_fonts_in_other_packages_(FAQ)
Comment 5 Hans Ulrich Niedermann 2009-01-11 11:06:22 EST
So... currently this package looks as follows:

Upstream archive name: terminus-font
Fedora source package: terminus-font
Fedora package with X11 fonts: terminus-font-x11
Fedora package with console fonts: terminus-fonts-console

In order to conform to the new guidelines, I'd need to

a) rename the package with the X11 fonts (and probably the source package) to "terminus-fonts" (with an "s" at the end)
b) Either move the console font to a separate source/binary package, or have the new "terminus-fonts" package create a subpackage like "terminus-fonts-console".

Is this correct?
Comment 6 Hans Ulrich Niedermann 2009-01-11 11:18:36 EST
Uhm. Forget comment #5. I had assumed this bug was for a different package.
Comment 7 Nicolas Mailhot 2009-01-11 11:27:33 EST
Yes, sorry, next time I'll make sure the script use different summaries for different packages.

Nevertheless to answer your comment what you wrote is correct (with the exception FPC is making noises about changing existing font package naming rules but I'm trying to dissuade them).
Comment 8 Hans Ulrich Niedermann 2009-01-11 19:58:47 EST
Well... this is what I have found out.

The ntedfont.pfa file appears (according to kfontview) to contain a number of special symbols for typesetting music, and a set of numbers.

I know of no tool to find out whether these symbols conform to any special unicode, or other encoding, or whether this is just a symbol font which maps the codes of some normal characters to the shapes of some special symbols.

In any case, it appears to be designed just for use within the nted application.

Now, I can install the ntedfont.pfa file into the new place required by the new font policy, and symlink it to the old location so that nted can find it. The ntedfont.pfa file will be shipped in its own separate subpackage nted-fonts, which nted will now require. That is no problem.

However, I'm not quite getting what to use as fontconfig file here:

a) "ruleset numeral prefix" only talks about fonts of characters, not of special symbols.
b) those special symbols fit into neither of the "sans-serif, serif, monospace, fantasy or cursive" standard families

Where can I find more information about the suitable prefix and the family?
Comment 9 Nicolas Mailhot 2009-01-12 02:12:37 EST
For symbol fonts you can skip the fontconfig bit, they mostly are one-of-a-kinds that don't really fit in existing classifications
Comment 10 Hans Ulrich Niedermann 2009-01-12 08:57:28 EST
I think this should be fixed in

nted-1.4.17-2.fc11
http://koji.fedoraproject.org/koji/taskinfo?taskID=1046825
Comment 11 Nicolas Mailhot 2009-01-12 18:43:35 EST
Looks ok. Since FPC is still discussing font packages naming details, -fonts is fine for now

Note You need to log in before you can comment on or make changes to this bug.