This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 477434 - Please convert to new font packaging guidelines
Please convert to new font packaging guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ogre (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F11-new-font-rules
  Show dependency treegraph
 
Reported: 2008-12-20 19:35 EST by Nicolas Mailhot
Modified: 2009-01-10 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 16:51:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-12-20 19:35:32 EST
This bug has been filed because we've detected your package includes one or several font files:                                                                                                                                                             repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq                                                                                                                                                             Unfortunately the script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.                                                                                                                                                              Otherwise, you should know that:                                                                                                                                                              - Fedora guidelines demand the packaging of fonts in a separate package or subpackage: http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages                                                                                - our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package. http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18) http://fedoraproject.org/wiki/Fedora_fonts_policy_package http://fedoraproject.org/wiki/Simple_fonts_spec_template http://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts                                                                                                                                                              Please make your package conform to the current guidelines in rawhide.                                                                                                                                                             If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.                                                                                                                                                              It is preferred to make a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family                                                                                                                                                              The new templates should make the creation of font subpackages easy and safe.                                                                                                                                                              The following packages have already been converted and can serve as examples: - andika-fonts - apanov-heuristica-fonts - bitstream-vera-fonts - charis-fonts - dejavu-fonts - ecolier-court-fonts - edrip-fonts - gfs-ambrosia-fonts - gfs-artemisia-fonts - gfs-baskerville-fonts - gfs-bodoni-classic-fonts - gfs-bodoni-fonts - gfs-complutum-fonts - gfs-didot-classic-fonts - gfs-didot-fonts - gfs-eustace-fonts - gfs-fleischman-fonts - gfs-garaldus-fonts - gfs-gazis-fonts - gfs-jackson-fonts - gfs-neohellenic-fonts - gfs-nicefore-fonts - gfs-olga-fonts - gfs-porson-fonts - gfs-solomos-fonts - gfs-theokritos-fonts - stix-fonts - yanone-kaffeesatz-fonts                                                                                                                                                           If you have any remaining questions about the new guidelines please ask them on fedora-fonts-list at redhat.com
Comment 1 Nicolas Mailhot 2008-12-20 19:56:39 EST
[Since the bot made a mess of the text here it is again in properly indented form.]

This bug has been filed because we've detected your package includes one or several font files:

repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq

Unfortunately this script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.

Otherwise, you should know that:

— Fedora guidelines demand the packaging of fonts in a separate package (or subpackage):
http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages

— our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package:
  – http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18)
  – http://fedoraproject.org/wiki/Fedora_fonts_policy_packagehttp://fedoraproject.org/wiki/Simple_fonts_spec_templatehttp://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts

Please make your package conform to the current guidelines in rawhide (you can use the fontpackages package in F9 or F10 to test, but only submit changes to rawhide please).

If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.

It is preferred to create a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on:
http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family

The new templates should make the creation of font subpackages easy and safe.

The following packages have already been converted by their packager and can serve as examples:
❄ andika-fonts
❄ apanov-heuristica-fonts
❄ bitstream-vera-fonts
❄ charis-fonts
❄ dejavu-fonts
❄ ecolier-court-fonts
❄ edrip-fonts
❄ gfs-ambrosia-fonts
❄ gfs-artemisia-fonts
❄ gfs-baskerville-fonts
❄ gfs-bodoni-classic-fonts
❄ gfs-bodoni-fonts
❄ gfs-complutum-fonts
❄ gfs-didot-classic-fonts
❄ gfs-didot-fonts
❄ gfs-eustace-fonts
❄ gfs-fleischman-fonts
❄ gfs-garaldus-fonts
❄ gfs-gazis-fonts
❄ gfs-jackson-fonts
❄ gfs-neohellenic-fonts
❄ gfs-nicefore-fonts
❄ gfs-olga-fonts
❄ gfs-porson-fonts
❄ gfs-solomos-fonts
❄ gfs-theokritos-fonts
❄ stix-fonts
❄ yanone-kaffeesatz-fonts

If you have any remaining questions about the new guidelines please ask them on:
fedora-fonts-list at redhat.com
Comment 2 Hans de Goede 2008-12-27 09:20:40 EST
* Sat Dec 27 2008 Hans de Goede <hdegoede@redhat.com> 1.6.0-3
- Remove non-free fonts from samples subpackage (rh 477434)
Comment 3 Nicolas Mailhot 2009-01-09 11:28:09 EST
Please consider linking to dejavu full and not lgc as full is installed on most Fedora systems while LGC is not
Comment 4 Hans de Goede 2009-01-10 08:03:52 EST
Ogre also uses condensed fonts in several places which are only available in the LGC version, closing again.

Note orge itself is not used much, and the demos (which require the fonts) are even less often installed. So this really is not much of an issue IMHO.
Comment 5 Nicolas Mailhot 2009-01-10 11:14:56 EST
(In reply to comment #4)
> Ogre also uses condensed fonts in several places which are only available in
> the LGC version, closing again.

What a strange notion, of course condensed is available in dejavu-full just like in dejavu-lgc
Comment 6 Hans de Goede 2009-01-10 11:28:25 EST
(In reply to comment #5)
> (In reply to comment #4)
> > Ogre also uses condensed fonts in several places which are only available in
> > the LGC version, closing again.
> 
> What a strange notion, of course condensed is available in dejavu-full just
> like in dejavu-lgc

[hans@localhost inf]$ ls /usr/share/fonts/dejavu/
DejaVuLGCSans-Bold.ttf                  DejaVuLGCSerif.ttf
DejaVuLGCSans-BoldOblique.ttf           DejaVuLGCSerifCondensed-Bold.ttf
DejaVuLGCSans-ExtraLight.ttf            DejaVuLGCSerifCondensed-BoldItalic.ttf
DejaVuLGCSans-Oblique.ttf               DejaVuLGCSerifCondensed-Italic.ttf
DejaVuLGCSans.ttf                       DejaVuLGCSerifCondensed.ttf
DejaVuLGCSansCondensed-Bold.ttf         DejaVuSans-Bold.ttf
DejaVuLGCSansCondensed-BoldOblique.ttf  DejaVuSans-BoldOblique.ttf
DejaVuLGCSansCondensed-Oblique.ttf      DejaVuSans-Oblique.ttf
DejaVuLGCSansCondensed.ttf              DejaVuSans.ttf
DejaVuLGCSansMono-Bold.ttf              DejaVuSansMono-Bold.ttf
DejaVuLGCSansMono-BoldOblique.ttf       DejaVuSansMono-BoldOblique.ttf
DejaVuLGCSansMono-Oblique.ttf           DejaVuSansMono-Oblique.ttf
DejaVuLGCSansMono.ttf                   DejaVuSansMono.ttf
DejaVuLGCSerif-Bold.ttf                 DejaVuSerif-Bold.ttf
DejaVuLGCSerif-BoldItalic.ttf           DejaVuSerif.ttf
DejaVuLGCSerif-Italic.ttf

Note:

This is F-10 so this may be fixed in rawhide, but I see no condensed versions of regular dejavu here.
Comment 7 Nicolas Mailhot 2009-01-10 11:53:42 EST
This is because you do not have the experimental dejavu subpackage installed.

Since it has not been experimental for quite a long time, and people like you were confused by the package split, F11 has a new package layout

$ rpm -ql dejavu-fonts-sans
/etc/fonts/conf.d/20-unhint-small-dejavu-sans.conf
/etc/fonts/conf.d/57-dejavu-sans.conf
/usr/share/fontconfig/conf.avail/20-unhint-small-dejavu-sans.conf
/usr/share/fontconfig/conf.avail/57-dejavu-sans.conf
/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf
/usr/share/fonts/dejavu/DejaVuSans-BoldOblique.ttf
/usr/share/fonts/dejavu/DejaVuSans-ExtraLight.ttf
/usr/share/fonts/dejavu/DejaVuSans-Oblique.ttf
/usr/share/fonts/dejavu/DejaVuSans.ttf
/usr/share/fonts/dejavu/DejaVuSansCondensed-Bold.ttf
/usr/share/fonts/dejavu/DejaVuSansCondensed-BoldOblique.ttf
/usr/share/fonts/dejavu/DejaVuSansCondensed-Oblique.ttf
/usr/share/fonts/dejavu/DejaVuSansCondensed.ttf

LGC is built from the same sources as dejavu by removing stuff so it can't have material not present in full
Comment 8 Hans de Goede 2009-01-10 16:51:31 EST
Ok, I changed it to use the full dejavu version now, closing again :)
Comment 9 Nicolas Mailhot 2009-01-10 17:07:32 EST
Thanks a lot

Note You need to log in before you can comment on or make changes to this bug.