Bug 477440 - Please convert to new font packaging guidelines
Please convert to new font packaging guidelines
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: php-ZendFramework (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Kahl
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F11-new-font-rules
  Show dependency treegraph
 
Reported: 2008-12-20 19:36 EST by Nicolas Mailhot
Modified: 2009-01-23 21:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-23 21:39:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-12-20 19:36:35 EST
This bug has been filed because we've detected your package includes one or several font files:                                                                                                                                                             repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq                                                                                                                                                             Unfortunately the script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.                                                                                                                                                              Otherwise, you should know that:                                                                                                                                                              - Fedora guidelines demand the packaging of fonts in a separate package or subpackage: http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages                                                                                - our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package. http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18) http://fedoraproject.org/wiki/Fedora_fonts_policy_package http://fedoraproject.org/wiki/Simple_fonts_spec_template http://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts                                                                                                                                                              Please make your package conform to the current guidelines in rawhide.                                                                                                                                                             If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.                                                                                                                                                              It is preferred to make a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family                                                                                                                                                              The new templates should make the creation of font subpackages easy and safe.                                                                                                                                                              The following packages have already been converted and can serve as examples: - andika-fonts - apanov-heuristica-fonts - bitstream-vera-fonts - charis-fonts - dejavu-fonts - ecolier-court-fonts - edrip-fonts - gfs-ambrosia-fonts - gfs-artemisia-fonts - gfs-baskerville-fonts - gfs-bodoni-classic-fonts - gfs-bodoni-fonts - gfs-complutum-fonts - gfs-didot-classic-fonts - gfs-didot-fonts - gfs-eustace-fonts - gfs-fleischman-fonts - gfs-garaldus-fonts - gfs-gazis-fonts - gfs-jackson-fonts - gfs-neohellenic-fonts - gfs-nicefore-fonts - gfs-olga-fonts - gfs-porson-fonts - gfs-solomos-fonts - gfs-theokritos-fonts - stix-fonts - yanone-kaffeesatz-fonts                                                                                                                                                           If you have any remaining questions about the new guidelines please ask them on fedora-fonts-list at redhat.com
Comment 1 Nicolas Mailhot 2008-12-20 19:56:47 EST
[Since the bot made a mess of the text here it is again in properly indented form.]

This bug has been filed because we've detected your package includes one or several font files:

repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq

Unfortunately this script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.

Otherwise, you should know that:

— Fedora guidelines demand the packaging of fonts in a separate package (or subpackage):
http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages

— our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package:
  – http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18)
  – http://fedoraproject.org/wiki/Fedora_fonts_policy_packagehttp://fedoraproject.org/wiki/Simple_fonts_spec_templatehttp://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts

Please make your package conform to the current guidelines in rawhide (you can use the fontpackages package in F9 or F10 to test, but only submit changes to rawhide please).

If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.

It is preferred to create a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on:
http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family

The new templates should make the creation of font subpackages easy and safe.

The following packages have already been converted by their packager and can serve as examples:
❄ andika-fonts
❄ apanov-heuristica-fonts
❄ bitstream-vera-fonts
❄ charis-fonts
❄ dejavu-fonts
❄ ecolier-court-fonts
❄ edrip-fonts
❄ gfs-ambrosia-fonts
❄ gfs-artemisia-fonts
❄ gfs-baskerville-fonts
❄ gfs-bodoni-classic-fonts
❄ gfs-bodoni-fonts
❄ gfs-complutum-fonts
❄ gfs-didot-classic-fonts
❄ gfs-didot-fonts
❄ gfs-eustace-fonts
❄ gfs-fleischman-fonts
❄ gfs-garaldus-fonts
❄ gfs-gazis-fonts
❄ gfs-jackson-fonts
❄ gfs-neohellenic-fonts
❄ gfs-nicefore-fonts
❄ gfs-olga-fonts
❄ gfs-porson-fonts
❄ gfs-solomos-fonts
❄ gfs-theokritos-fonts
❄ stix-fonts
❄ yanone-kaffeesatz-fonts

If you have any remaining questions about the new guidelines please ask them on:
fedora-fonts-list at redhat.com
Comment 2 Alexander Kahl 2008-12-23 10:03:17 EST
Files in question:

$ rpm -qa php-ZendFramework\*|xargs -n1 rpm -ql|grep -E '\.(ttf|otf|pfb|pfa)$'
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/Vera.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraBI.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraBd.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraIt.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraMoBI.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraMoBd.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraMoIt.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraMono.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraSe.ttf
/usr/share/php/Zend/tests/Zend/Pdf/_fonts/VeraSeBd.ttf

(from php-ZendFramework-tests)

These font files are part of Zend Framework's tests package and used to determine whether the PDF extension works correctly.

They are identical to the ones in Fedora's bitstream-vera-fonts package, thus there are no licensing issues:

/usr/share/fonts/bitstream-vera $ sha1sum *.ttf > /tmp/sha
/usr/share/php/Zend/tests/Zend/Pdf/_fonts $ sha1sum -c /tmp/sha
VeraBd.ttf: OK
VeraBI.ttf: OK
VeraIt.ttf: OK
VeraMoBd.ttf: OK
VeraMoBI.ttf: OK
VeraMoIt.ttf: OK
VeraMono.ttf: OK
VeraSeBd.ttf: OK
VeraSe.ttf: OK
Vera.ttf: OK


If you still consider this a bug, we can either patch the source code (heavily discouraged) or symlink the files from bitstream-vera-fonts and create a dependency on the package; in either case, please reopen this bug report.
Comment 3 Nicolas Mailhot 2008-12-23 10:57:00 EST
Please symlink from the Vera (or better) DejaVu packages
Comment 4 Fedora Update System 2009-01-02 08:03:02 EST
php-ZendFramework-1.7.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/php-ZendFramework-1.7.2-1.fc10
Comment 5 Alexander Kahl 2009-01-02 08:12:50 EST
Updates for F-9 and F-10 submitted for testing.
Package cannot be built for rawhide right now because of missing F-11 bitstream-vera-fonts, so it seems.. clueless.
Comment 6 Nicolas Mailhot 2009-01-02 09:40:51 EST
The font packages in rawhide have been reorganised

https://www.redhat.com/archives/fedora-fonts-list/2008-December/msg00025.html
Comment 7 Alexander Kahl 2009-01-02 10:12:32 EST
The name of the fonts in the unit test is hardcoded.. I'm trying hard to avoid patching the source file; it seems there are no checks on whether the expected list of files really refers to the Vera family, I could make the symlinks point to the DejaVu family I guess.
Comment 8 Nicolas Mailhot 2009-01-03 04:42:22 EST
It's worth a try.
You could also remind upstream to add fontconfig support so it can auto-discover system fonts like other apps
Comment 9 Fedora Update System 2009-01-07 04:16:58 EST
php-ZendFramework-1.7.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-ZendFramework'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0094
Comment 10 Nicolas Mailhot 2009-01-14 13:37:44 EST
FPC approved those two additional guidelines recently, please take them into account if you need to create or update a fonts package or subpackage:

– 2009-01-14: naming
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_naming_%282009-01-13%29

— 2009-01-06: exact splitting rules
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_splitting_rules_%282008-12-21%29

(packagers that can drop font files and just depend on an existing font package are not impacted)
Comment 11 Fedora Update System 2009-01-23 21:39:56 EST
php-ZendFramework-1.7.2-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.