This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 477481 - [wastesedge] Please convert to new font packaging guidelines
[wastesedge] Please convert to new font packaging guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wastesedge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mathieu Bridon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11-new-font-rules
  Show dependency treegraph
 
Reported: 2008-12-20 19:43 EST by Nicolas Mailhot
Modified: 2009-03-15 16:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-15 16:07:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-12-20 19:43:42 EST
This bug has been filed because we've detected your package includes one or several font files:                                                                                                                                                             repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq                                                                                                                                                             Unfortunately the script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.                                                                                                                                                              Otherwise, you should know that:                                                                                                                                                              - Fedora guidelines demand the packaging of fonts in a separate package or subpackage: http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages                                                                                - our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package. http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18) http://fedoraproject.org/wiki/Fedora_fonts_policy_package http://fedoraproject.org/wiki/Simple_fonts_spec_template http://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts                                                                                                                                                              Please make your package conform to the current guidelines in rawhide.                                                                                                                                                             If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.                                                                                                                                                              It is preferred to make a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family                                                                                                                                                              The new templates should make the creation of font subpackages easy and safe.                                                                                                                                                              The following packages have already been converted and can serve as examples: - andika-fonts - apanov-heuristica-fonts - bitstream-vera-fonts - charis-fonts - dejavu-fonts - ecolier-court-fonts - edrip-fonts - gfs-ambrosia-fonts - gfs-artemisia-fonts - gfs-baskerville-fonts - gfs-bodoni-classic-fonts - gfs-bodoni-fonts - gfs-complutum-fonts - gfs-didot-classic-fonts - gfs-didot-fonts - gfs-eustace-fonts - gfs-fleischman-fonts - gfs-garaldus-fonts - gfs-gazis-fonts - gfs-jackson-fonts - gfs-neohellenic-fonts - gfs-nicefore-fonts - gfs-olga-fonts - gfs-porson-fonts - gfs-solomos-fonts - gfs-theokritos-fonts - stix-fonts - yanone-kaffeesatz-fonts                                                                                                                                                           If you have any remaining questions about the new guidelines please ask them on fedora-fonts-list at redhat.com
Comment 1 Nicolas Mailhot 2008-12-20 19:57:42 EST
[Since the bot made a mess of the text here it is again in properly indented form.]

This bug has been filed because we've detected your package includes one or several font files:

repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq

Unfortunately this script does not detect symlinks to other packages, so if that's your case, you can close this bug report now.

Otherwise, you should know that:

— Fedora guidelines demand the packaging of fonts in a separate package (or subpackage):
http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages

— our font packaging guidelines recently changed, and every package that ships fonts must be adapted to the new templates available in the fontpackages-devel package:
  – http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18)
  – http://fedoraproject.org/wiki/Fedora_fonts_policy_packagehttp://fedoraproject.org/wiki/Simple_fonts_spec_templatehttp://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts

Please make your package conform to the current guidelines in rawhide (you can use the fontpackages package in F9 or F10 to test, but only submit changes to rawhide please).

If your package is not principaly a font package, depending on a separate font package or subpackage is the prefered solution. If your application does not use fontconfig you can always package symlinks to the files provided by the font package and installed in the correct fontconfig directories.

It is preferred to create a font package or subpackage per font family, though it is not currently a hard guidelines requirement (it may become before Fedora 11 is released). The definition of a font family is given on:
http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family

The new templates should make the creation of font subpackages easy and safe.

The following packages have already been converted by their packager and can serve as examples:
❄ andika-fonts
❄ apanov-heuristica-fonts
❄ bitstream-vera-fonts
❄ charis-fonts
❄ dejavu-fonts
❄ ecolier-court-fonts
❄ edrip-fonts
❄ gfs-ambrosia-fonts
❄ gfs-artemisia-fonts
❄ gfs-baskerville-fonts
❄ gfs-bodoni-classic-fonts
❄ gfs-bodoni-fonts
❄ gfs-complutum-fonts
❄ gfs-didot-classic-fonts
❄ gfs-didot-fonts
❄ gfs-eustace-fonts
❄ gfs-fleischman-fonts
❄ gfs-garaldus-fonts
❄ gfs-gazis-fonts
❄ gfs-jackson-fonts
❄ gfs-neohellenic-fonts
❄ gfs-nicefore-fonts
❄ gfs-olga-fonts
❄ gfs-porson-fonts
❄ gfs-solomos-fonts
❄ gfs-theokritos-fonts
❄ stix-fonts
❄ yanone-kaffeesatz-fonts

If you have any remaining questions about the new guidelines please ask them on:
fedora-fonts-list at redhat.com
Comment 2 Mathieu Bridon 2008-12-22 17:32:24 EST
Hi

First of all, I'd like to thank you for this report, I wasn't aware of the fonts issue (one always learn :).

This is particularly a good timing as I'm about to submit a new package in Fedora, and it also contains some fonts ^_^

Anyway, back on Waste's Edge.

I contacted the developer, and he told me that only two fonts are included:
/usr/share/adonthell/games/wastesedge/gfx/window/font/*/font.font
/usr/share/adonthell/games/wastesedge/gfx/window/font/avatar.ttf

The first one is a bitmap one that was specifically created for the game. Kai (Adonthell / Waste's Edge lead dev) contacted the original author to have precisions about the font license. This one should not be a problem, I'll simply create a subpackage wastesedge-fonts for it. That should do it if I correctly understood the packaging policy on fonts. Could someone confirm ?

However, the second one might cause a little more trouble. It is a True Type font that was created by a fan of the Ultima game [1] [2]

I tried contacting him, asking for more informations about his font license, but it looks like the email address provided on his website is not valid anymore.

I'm not sure what I can do here, any idea ? :-/


[1] http://ultima.gogab.com/
[2] http://ultima.gogab.com/avtrfont.zip
Comment 3 Nicolas Mailhot 2008-12-22 18:04:32 EST
For the first font, a subpackage would be fine, even though you'll not I didn't search for *.font files in repoquery, so those can rot in peace a little longer (but a subpackage is always better than a private font)

For the second font it only says "Avatar font by C.J. Ellsworth" so you need to track this person to get a proper license (OFL or GPL+font exception are good)

You can also try the http://www.myfonts.com/WhatTheFont/ service to see if it finds you a new contact.

The font is in Debian so you can ask Debian-side if they have a current contact.

If you can't you have to drop the font in Fedora.

Spot may have other suggestions.

See also:
http://fedoraproject.org/wiki/Legal_considerations_for_fonts
Comment 4 Mathieu Bridon 2008-12-29 06:50:21 EST
* First font: font.font

I discussed it with the Adonthell devs, and in fact, this is not really a font. This is more like some picture and data used to render text with custom code in Adonthell.

This means that such a "font" can not be used in other apps, say OOo for example.

So, this doesn't make any sense splitting it in a subpackage and installing it system-wide.

* Second font: avatar.ttf

I contacted the 2 maintainers of the Adonthell package in Debian, both emails are unexisting o_O

I might have one more way to contact the author of the font.

However, I started playing with the spec file to remove the font totally from the game, and make it use one of the system fonts.

I'm in contact with the Adonthell devs about how to do that properly and which one they would less dislike.

So, working on it, just a status report :)
Comment 5 Jon Stanley 2009-01-04 10:55:40 EST
fixing dependencies as not to bring FE-LEGAL into F11Target :)
Comment 6 Nicolas Mailhot 2009-01-11 10:20:39 EST
To help packagers manage the transition to the new guidelines, we've published the following FAQ

http://fedoraproject.org/wiki/Shipping_fonts_in_other_packages_(FAQ)
Comment 7 Nicolas Mailhot 2009-01-14 13:38:21 EST
FPC approved those two additional guidelines recently, please take them into account if you need to create or update a fonts package or subpackage:

– 2009-01-14: naming
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_naming_%282009-01-13%29

— 2009-01-06: exact splitting rules
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_splitting_rules_%282008-12-21%29

(packagers that can drop font files and just depend on an existing font package are not impacted)
Comment 8 Mathieu Bridon 2009-01-28 09:02:35 EST
* I tried to contact the Debian Games SIG that is maintaining Adonthell / Waste's Edge in Debian and got no response from them.

* I tried to contact to person on Facebook named C.J. Ellsworth to ask them if they were the author of this font, neither of them answered.

=> I assume I won't be able to get any more information about the license of the avatar.ttf font.

Does this mean I must assume the font is not free and must be removed from the package in Fedora ?

If so, then I guess I'll have to rebuild the package for F9, F10 and Rawhide, whereas simply conforming to the recent font guideline would have meant I needed to rebuild only for Rawhide ? (only to be sure I'm fully understanding the issues ;)
Comment 9 Nicolas Mailhot 2009-01-28 09:47:57 EST
I'd say that yes, if you have no proof the font is floss you have to assume it isn't, and if there is a legal problem you need to rebuild in all branches.

However, do not hesitate to discuss it with spot (either on IRC or by e-mail). He has the final say on legal problems.
Comment 10 Tom "spot" Callaway 2009-02-12 13:47:11 EST
If we cannot determine the license of a file, we cannot include it. Please remove the avatar font from all branches and push updates.
Comment 11 Mathieu Bridon 2009-02-13 18:06:34 EST
Just removed it. Upstream said they might not ship it any more in their next release.

Building right now on Koji for F9, F10 and Rawhide.

Will land in the repositories soon.
Comment 12 Mathieu Bridon 2009-02-18 04:54:09 EST
I'm wondering something: I remove the font at %prep time, which means it is still included in the srpm right ?

Is that a potential legal issue ?
Comment 13 Tom "spot" Callaway 2009-02-18 10:08:12 EST
Yep. You need to make a modified tarball that doesn't have that font.
Comment 14 Nicolas Mailhot 2009-02-18 14:33:05 EST
This is a reminder for all the packagers that still have bugs open about adapting to font packaging guidelines there is only one month left before Fedora 11 beta:
http://fedoraproject.org/wiki/Releases/11/Schedule

A week of this month will see the Fedora 11 mass rebuild, that will load the build farm:
http://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

As already converted packages showed it is quite possible to make mistakes during the conversion. Please make releng and QA happy and don't wait till the last minute to do your changes (avoid pre-beta panic). If possible start before the mass rebuild so we don't burn cycles on incorrect packages.

The PackageKit enhancements stated for Fedora 11 assume fonts and font-using packages are sane (basically respect packaging guidelines). It is quite possible that not-converted packages will interact with the F11 font autoinstall feature in "interesting" ways.
http://fedoraproject.org/wiki/Features/AutomaticFontInstallation

We don't want that

There is extensive documentation on the wiki and most of your questions have likely already been answered there. Please do read the FAQ before making more work for the support team by asking questions answered there.
http://fedoraproject.org/wiki/Shipping_fonts_in_Fedora_%28FAQ%29
Comment 15 Fedora Update System 2009-03-01 08:24:40 EST
wastesedge-0.3.4-0.12.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/wastesedge-0.3.4-0.12.fc9
Comment 16 Fedora Update System 2009-03-01 08:32:43 EST
wastesedge-0.3.4-0.12.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/wastesedge-0.3.4-0.12.fc10
Comment 17 Mathieu Bridon 2009-03-01 11:46:07 EST
The two updates from today were rebuilt without the illegal font in the SRPM.

They should land in the Fedora repositories soon.

I'd be glad if someone wants to check that I didn't forget anything, as this is a legal issue and I wouldn't want to cause any trouble.

I'll close the bug next week, when the updates are in the stable repositories for F-9 and F-10.
Comment 18 Fedora Update System 2009-03-11 14:00:17 EDT
wastesedge-0.3.4-0.12.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2009-03-11 14:00:32 EDT
wastesedge-0.3.4-0.12.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Tom "spot" Callaway 2009-03-12 11:29:29 EDT
Lifting FE-Legal.

Note You need to log in before you can comment on or make changes to this bug.