Bug 477497 - [PATCH] Warnings shown using certain locales
[PATCH] Warnings shown using certain locales
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: supertux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-12-20 22:40 EST by Lubomir Rintel
Modified: 2009-01-18 16:10 EST (History)
1 user (show)

See Also:
Fixed In Version: supertux-0.3.1-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-18 16:10:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Parse supertux's PO files correctly (1.22 KB, text/plain)
2008-12-20 22:40 EST, Lubomir Rintel
no flags Details
Disable the debugging console (596 bytes, patch)
2008-12-20 22:45 EST, Lubomir Rintel
no flags Details | Diff

  None (edit)
Description Lubomir Rintel 2008-12-20 22:40:55 EST
Created attachment 327557 [details]
Parse supertux's PO files correctly

When using most of the locales (if not all), useless and confusing warning are show in the top part of the screen, due to various bugs in the PO file parser (tinygettext).

How to reproduce:

LANG=fi supertux
LANG=cs_CZ supertux

A patch is attached to address the problem.
Comment 1 Lubomir Rintel 2008-12-20 22:45:26 EST
Created attachment 327558 [details]
Disable the debugging console

Probably the debugging console should not be presented to game player at all. Messages about a frame being skipped or audio being reset are only of interest to the developer, which the 0.3.1 release is targeted at.

Since we consider this, against upstream recommendations, stable, we should not enable development hacks on. The very same information that is presented in the console is dumped to stderr anyways, so we don't loose any information here.
Comment 2 Lubomir Rintel 2009-01-02 07:30:02 EST
Ping
Comment 3 Lubomir Rintel 2009-01-18 16:10:32 EST
Fixed in supertux-0.3.1-4.fc11.
Upstream developer notified about the patch, tracking it.

Note You need to log in before you can comment on or make changes to this bug.