Bug 477512 - Kmail crashes when it cannot resolve domain
Kmail crashes when it cannot resolve domain
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Lorenzo Villani
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 08:06 EST by Nicolas Troncoso Carrere
Modified: 2009-07-22 10:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 10:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback (2.01 KB, application/octet-stream)
2008-12-21 08:06 EST, Nicolas Troncoso Carrere
no flags Details
Aditional Trace back when reproducing. (2.04 KB, application/octet-stream)
2008-12-21 08:07 EST, Nicolas Troncoso Carrere
no flags Details

  None (edit)
Description Nicolas Troncoso Carrere 2008-12-21 08:06:17 EST
Created attachment 327576 [details]
Traceback

Description of problem:
If kmail is unable to resolve a domain (mail.foo.bar) because the authoritative dns for foo.bar is no where to be found, it displays the unknown host mail.foo.bar message. Then after a minute or so it crashed.
My setting with mail.foo.bar is imaps. Interval check of 2 minutes.

Version-Release number of selected component (if applicable):
kdepim-4.1.3-1.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Configure an imap account in a foo server
2. Nuke the resolver for the foo server
3. check your mail
  
Actual results:
Kmail displays the unknown host message and crashed.

Expected results:
Kamil displays the unknown host message

Additional info:
I attach a traceback
Comment 1 Nicolas Troncoso Carrere 2008-12-21 08:07:22 EST
Created attachment 327577 [details]
Aditional Trace back when reproducing.
Comment 2 Lorenzo Villani 2009-07-22 09:39:43 EDT
Cannot reproduce here (w/ kdepim 4.2.96).
Can you provide more information or test a newer package kdepim version? Going to close as WORKSFORME if no further problems are reported in two weeks.
Comment 3 Nicolas Troncoso Carrere 2009-07-22 10:08:46 EDT
I tried to reproduce the problem. This seems to have been fixed in some version since 4.1.

Go ahead and Close the ticket.
Comment 4 Lorenzo Villani 2009-07-22 10:51:41 EDT
Thanks for testing again.

Note You need to log in before you can comment on or make changes to this bug.