Bug 477532 - click open the channel tree under channels tab and the channel disappears
click open the channel tree under channels tab and the channel disappears
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Preethi Thomas
:
Depends On:
Blocks: 456998 457078
  Show dependency treegraph
 
Reported: 2008-12-21 11:59 EST by Pradeep Kilambi
Modified: 2009-09-10 15:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:18:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2008-12-21 11:59:35 EST
Description of problem:
Channels disappear when you try to span open the tree structure to see child channels.

How reproducible:
always

Steps to Reproduce:
1. got to channels tab
2. click (+) channelname
3. click again to close the tree and the channel disappears
4. refresh the page and channel is back

I guess some mischief in jsp?


~ Prad
Comment 1 Justin Sherrill 2009-01-30 14:12:54 EST
Looks like this was introduced by multiorg and not by the original channel refactoring.  If you change the # of columns in the channel tree view you have to set that # in onLoadStuff(4) within the jsp.

Fixed.
Comment 2 Preethi Thomas 2009-02-11 08:09:57 EST
verified. 
Satellite-5.3.0-RHEL5-re20090206.1-i386-embedded-oracle.iso
followed the testplan
Comment 3 Miroslav Suchý 2009-08-26 10:22:06 EDT
verified on both null channel and custom channel
verified in stage on dell-pem710-01.rhts.eng.bos.redhat.com
Comment 4 Brandon Perkins 2009-09-10 15:18:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.