Bug 477541 - Kde3 programs crash at start: "Communication problem with kded"
Kde3 programs crash at start: "Communication problem with kded"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdelibs3 (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 14:35 EST by info
Modified: 2008-12-22 05:28 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 05:28:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description info 2008-12-21 14:35:26 EST
Description of problem:

kde3 programs crash immediately when started. I've tried this with k3b, kmymoney, kpowersave and ksynaptcs, it's always the same. when started from command line, the error is:

$ k3b
kded: ERROR: KUniqueApplication: Registering failed!
kded: ERROR: Communication problem with kded, it probably crashed.
DCOP aborting call from 'anonymous-5664' to 'k3b'
KCrash: Application 'k3b' crashing...


Version-Release number of selected component (if applicable):

Fedora 10 with all updates as of today.

How reproducible:

Always.

Steps to Reproduce:
1. Start any kde3 programme
  
Actual results:
Crash

Expected results:
no crash

Additional info:

I've tried uninstalling all kde packages and reinstalling but it didn't help. A search for the error message didn't get me to anything useful. I've no idea what other information is need to solve this, so please tell me what I should try.
Comment 1 Rex Dieter 2008-12-21 17:04:24 EST
rpm -q kdelibs3
and 
rpm -V kdelibs3
please

Otherwise, logout, try:
rm -rf /tmp/kde-<username>
rm -rf /var/tmp/kdecache-<username>
Comment 2 info 2008-12-22 04:15:50 EST
Hi Rex, thanks for your suggestions.

$ rpm -q kdelibs3
kdelibs3-3.5.10-1.fc10.x86_64

$ rpm -V kdelibs3
doesn't return anything. 

I logged out into text console, removed the two tmp directories, rebooted, but the programs still crash with the same error.
Comment 3 info 2008-12-22 05:28:15 EST
Hi again, I found the problem.

Your suggestion gave me the idea to check all installed packages for integrity. It turned out that qt3 had a problem:

$ rpm -V qt3
..5.....    /usr/lib64/qt-3.3/lib/libqt-mt.so.3.3.8

So I reinstalled qt3 and it works now.

Cheers
Stephan

Note You need to log in before you can comment on or make changes to this bug.