Bug 477552 - Cannot get DEAD KEYS (accents) in QT apps, when using GNOME (Was: Can't type the accent mark of the Greek Alphabet in Qt apps)
Cannot get DEAD KEYS (accents) in QT apps, when using GNOME (Was: Can't type ...
Status: CLOSED DUPLICATE of bug 468590
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 16:59 EST by DemetrisK
Modified: 2009-04-02 03:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-04 14:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description DemetrisK 2008-12-21 16:59:11 EST
User-Agent:       Opera/9.62 (X11; Linux i686; U; en) Presto/2.1.1

When using the GNOME Desktop Environment in Fedora 10, user is not able to type the accent mark of the Greek Alphabet (Οξεία or Acute "´") on apps using the Qt Toolkit (versions 3 and 4 tested). Instead of the acute to appear above of the vowel, it's placed in front of it (´α insteal of ά, ´η instead of ή and so on)

Reproducible: Always

Steps to Reproduce:
1.Install Modern Greek Locale
2.Intall a Qt app (like Opera Browser or the Last.fm Client)
3.Try typing accented Greek vowels (Press the ";" key and a vowel)
Actual Results:  
Text looks like:
"Κε´ιμενο στα ελληνικ´α"

Expected Results:  
But it should look like:
"Κείμενο στα ελληνικά"

My Default System Locale
[*******@localhost ~]$ locale
LANG=el_GR.UTF-8
LC_CTYPE="el_GR.UTF-8"
LC_NUMERIC="el_GR.UTF-8"
LC_TIME="el_GR.UTF-8"
LC_COLLATE="el_GR.UTF-8"
LC_MONETARY="el_GR.UTF-8"
LC_MESSAGES="el_GR.UTF-8"
LC_PAPER="el_GR.UTF-8"
LC_NAME="el_GR.UTF-8"
LC_ADDRESS="el_GR.UTF-8"
LC_TELEPHONE="el_GR.UTF-8"
LC_MEASUREMENT="el_GR.UTF-8"
LC_IDENTIFICATION="el_GR.UTF-8"
LC_ALL=
Comment 1 Simos Xenitellis 2009-01-04 08:17:43 EST
This appears to be some strange configuration issue, and I think up to now, it happens to QT applications that are installed on a GNOME Desktop.

The important issue to check here is whether it is possible to add any accents with other keyboard layouts (such as the French layout).

Could you please check that?
Comment 2 DemetrisK 2009-01-04 09:07:57 EST
I can type Latin accents as long are in a "single key".
exemple: éèèçù for AZERTY/French
But when I want to type a vowel accented with circumflex in AZERTY I have to use two keys (it's called Compose, isn't it?). 
The result is: ^e (same as in Greek layout)

So, I think it has to do with the "Dead keys" and how Qt deals with them.
Comment 3 Simos Xenitellis 2009-01-04 10:21:42 EST
Thanks Demetris.

Therefore, the problem appears to be about «Cannot get Compose sequences/accents in QT apps, when using GNOME», and is something that affects some users only.

This is a tricky issue to deal with, because it is not clear which upstream project should be involved.
Could you please have a look at

1. QT Tast tracker,
http://trolltech.com/developer/task-tracker

2. KDE Bug tracking,
https://bugs.kde.org/

In addition, could you please check whether you have 'SCIM/Support for complex writing' enabled on your system? I am not sure where you need to look in Fedora.
You might need to disable 'SCIM'.
Comment 4 DemetrisK 2009-01-04 10:55:32 EST
//In addition, could you please check whether you have 'SCIM/Support for complex
writing' enabled on your system? I am not sure where you need to look in
Fedora.
You might need to disable 'SCIM'.//
Actually it's not even installed.
Comment 5 Simos Xenitellis 2009-01-04 11:11:28 EST
(In reply to comment #4)
> //In addition, could you please check whether you have 'SCIM/Support for
> complex
> writing' enabled on your system? I am not sure where you need to look in
> Fedora.
> You might need to disable 'SCIM'.//
> Actually it's not even installed.

Thanks for verifying this.

Thus, you would need to bring people that know how QT and/or KDE use compose tables.

In addition to the bug trackers I mentioned above, you could also talk with KDE users on Freenode (IRC), at the relevant channels.
Comment 6 DemetrisK 2009-01-04 12:11:29 EST
Simos, the guys in IRC told me is not a "compose key" problem but "dead keys" (I mentioned that in C#2) , so i changed the bug name
Comment 7 Simos Xenitellis 2009-01-04 12:36:01 EST
Demetris, both types of sequences with either dead key or compose key are called 'compose sequences'. Above I mentioned 'compose sequences'. In addition to this, I would expect that if dead key compose sequences do not work, then compose key compose sequences would not work either.

There is one more thing you can check.
See if any of the variables 
 XMODIFIERS
 GTK_IM_MODULE
 QT_IM_SWITCHER
 QT_IM_MODULE
are set.

Normally, they should not be set.

You can open a terminal window and set the QT_IM_MODULE variable to 'xim' (export QT_IM_MODULE=xim') and then start the QT application. See if accents work now.
Comment 8 DemetrisK 2009-01-04 12:51:54 EST
How do I set these variables?

>Demetris, both types of sequences with either dead key or compose key are
>called 'compose sequences'
OK, I stand corrected. Anyway, deadkeys is more specific
Comment 9 Kevin Kofler 2009-01-04 14:03:30 EST

*** This bug has been marked as a duplicate of bug 468590 ***
Comment 10 George Dimitropoulos 2009-03-12 11:30:25 EDT
All relevant bugs are closed one way or another, but the bug is still here.

In my humble opinion it is a configuration bug, because in LyX in fedora 10 it does it when I use a regular user account, but not as ROOT!

If I login as root from a gnome terminal window of another user and run LyX and type ;a with a greek layout, I get ά, if I do it as a regural user, I get 'α.

Please fix it, because it "kills" me, I advise ppl to use fedora 9 that doesn't have it.

Note You need to log in before you can comment on or make changes to this bug.