Bug 477554 - Unable to change default language
Unable to change default language
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 17:23 EST by Alexey Kuznetsov
Modified: 2008-12-22 06:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 06:38:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2008-12-21 17:23:19 EST
Unable to change default language in: Options/Language Settings/Languages/Default languages for documents/Western.

I tried change it from English to Russian, after clicking OK and reopen setting i got prevoius value (English)

Installed
openoffice.org-langpack-ru-3.0.0-9.10.fc10.i386
openoffice.org-langpack-en-3.0.0-9.10.fc10.i386
Comment 1 Caolan McNamara 2008-12-21 18:00:01 EST
what is the output of 
> locale
more that likely it is some English variant. The tickbox is set for "current document only", so it affects only the document that is open. If you want to use Russian for all new document, then if you set your locale to Russian it tracks that, i.e. should do the same thing as e.g. gedit given the same set of settings.
Comment 2 Alexey Kuznetsov 2008-12-21 18:08:20 EST
of course > locale show
LANG=en_US.UTF-8

but, that option called "Default languages for documents" and that option work as i explain (it should be changed when i change it, and reopen setting) on OS X platform, and probably as under windows.

i can try to install openoffice on my windows host, but i shure i got same result as under os x.
Comment 3 Caolan McNamara 2008-12-22 06:38:52 EST
The tickbox is tickable/untickable on those platforms to enable it to affect all future documents, It's not untickable on the Fedora version, so it only can affect the current document. That's deliberate, so that the default langauge for new documents tracks the language of the locale if/when it changes, i.e. like everything else in Fedora does. 

A better design would be to have an additional "default" option in the dropdown which could be used as the default so the locale language is always used and if the locale changes then new documents use that locale language but it could still be changed manually to lock it to one language for all new documents. I'm working on that, but the current situation is deliberate not a bug.

Note You need to log in before you can comment on or make changes to this bug.