Bug 477555 - oocalc hangs exporting to PDF
oocalc hangs exporting to PDF
Status: CLOSED DUPLICATE of bug 477174
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 17:30 EST by Horst H. von Brand
Modified: 2009-01-05 08:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 08:43:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace from hung oocalc (5.33 KB, application/octet-stream)
2009-01-05 08:22 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2008-12-21 17:30:01 EST
Description of problem:
I have a spreadcheet with a print range (with custom header). When I try to export to PDF, oocalc hangs. Trying to print to a file says there is no print range defined. Editing the print range shows it ust fine, after that printing works.

Version-Release number of selected component (if applicable):
openoffice.org-calc-3.0.1-14.1.fc11.x86_64

How reproducible:
TRied several times with the same file, same results.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2008-12-21 18:06:01 EST
going to need an example
Comment 2 Horst H. von Brand 2008-12-22 12:58:05 EST
Sent an example (sorry, confidential data) directly to Caolan.
Comment 3 Horst H. von Brand 2008-12-26 10:37:05 EST
Still the same with openoffice.org-calc-3.0.1-14.2.fc11.x86_64
Comment 4 Caolan McNamara 2008-12-29 18:26:21 EST
Nah, I don't get this problem. Is there any additional step I have to take above loading the .ods and using "export as pdf" and just whacking ok at every step ?
Comment 5 Horst H. von Brand 2008-12-29 19:49:21 EST
OK, I did:

  cd where/the/file/lives
     # Here there is a file.pdf (previously exported)
  oocalc file.ods
     <click on the "Export as PDF" button>

  Hang!

Also:

   cd /tmp
     # Here there also is a file.pdf
   oocalc where/the/file/lives/file.ods
     <click on the "Export as PDF" button>

  Hang!

In any case, after moving file.pdf out of the way, it hangs just the same. This is not the problem.

Moved ~/.openoffice.org out of the way, same result.

I'm stumped.
Comment 6 Caolan McNamara 2009-01-05 06:04:47 EST
I bet this is the same problem as afflicts a lot of usages of gtk dialogs in OOo at the moment, i.e. bug 477174

to test that theory, get it to hang for you. get the pid of the process, e.g. ps auxw|grep openoffice

gdb
(gdb) attach thepid
(gdb) bt

and post the output of the backtrace here. I'm guessing we'll see XIfEvent and gdk_x11_get_server_time in there
Comment 7 Horst H. von Brand 2009-01-05 08:22:11 EST
Created attachment 328194 [details]
Backtrace from hung oocalc

Did as told in #6. Yes, at frames 5 and 6 there are XIfEvent and gdk_x11_get_server_time. Should this be closed as a duplicate of 477174?
Comment 8 Caolan McNamara 2009-01-05 08:43:00 EST
Yeah, another manifestation of that problem.

*** This bug has been marked as a duplicate of bug 477174 ***

Note You need to log in before you can comment on or make changes to this bug.