Bug 477564 - yum: High memory-usage with big rpms
yum: High memory-usage with big rpms
Status: CLOSED DUPLICATE of bug 472507
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 19:13 EST by Reindl Harald
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 14:04:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2008-12-21 19:13:54 EST
Hi

This day i refreshed the vmware-tools on some guests with "yum --nogpgcheck localupdate", the package has 91M and is shown with over 200MB from yum

It is nearly impossible to get this running in a vm with 768MB RAM because the swap-usage reaches 1600 MB after a short time

Doing the same with "rpm -Uvh VMwareTools-2.0.0-122956.i386.rpm" instead of "yum --nogpgcheck localupdate VMwareTools-2.0.0-122956.i386.rpm" runs very fast and without any troubles.

For me it seems that something will be copied more than once in memory
Maybe this could be fixed 

___

Version: yum-3.2.20-5.fc9.noarch
Comment 1 James Antill 2008-12-22 00:41:42 EST
Can you see _when_ the memory is being used up, does it happen before the "entering rpm code" sections?
Comment 2 Reindl Harald 2008-12-22 20:36:21 EST
As far as i remember after
The really explode happens after successful transaction-check
Seems that this will not happen on my fedora10-vms at home

The problem was on F9-guests in our company last night and after the second one i switched to "rpm" instead of "yum" an wondered how fast it runs

___

Here the directory-listing and involved scripts i used at F9/F10 on ESXi, VMware-Server 2.0 and VMware Fusion - The pain was VMware-Fusion because there is not enough RAm behind - Maybe that the fedora-host runninger VMware-Server with the fc10 machines does not have the problem because of its 8 GB RAM, the fusion host is a macosx with only 5 GB

The ESXi on a HP with 16 GB RAM ha easy to handle

________


[root@fedora-x64:/data/open-vm-tools]$ ls
insgesamt 95M
-rw-r--r-- 1 500 501 3,2M 2008-11-19 15:18 open-vm-tools-2008.11.18-130226.tar.gz
-r--r--r-- 1 500 501  91M 2008-12-21 17:31 VMwareTools-2.0.0-122956.i386.rpm
-rwx------ 1 500 501  326 2008-08-18 07:15 build.sh
-rwx------ 1 500 501  219 2008-12-21 22:44 update-vmware-tools.sh

[root@fedora-x64:/data/open-vm-tools]$ cat update-vmware-tools.sh
#!/bin/bash
KERNEL_VERSION=$(uname -r)
cd /data/open-vm-tools/
yum --nogpgcheck -y localupdate VMwareTools*.rpm
./build.sh
/bin/rm -f /lib/modules/$KERNEL_VERSION/misc/vm*
/usr/bin/vmware-config-tools.pl -d
/sbin/service network restart

[root@fedora-x64:/data/open-vm-tools]$ cat build.sh
#!/bin/bash
 tar -xzf open-vm-tools-*.gz
  cd open-vm-tools-*/modules/linux
  modsrc="/usr/lib/vmware-tools/modules/source"
  for x in `ls -d v*`
  do
     mv $x ${x}-only
     tar -cf $x.tar ${x}-only
     mv ${x}-only $x
     mv $modsrc/$x.tar $modsrc/$x.tar.orig
     mv $x.tar $modsrc
  done
Comment 3 Panu Matilainen 2008-12-23 01:45:30 EST
> The really explode happens after successful transaction-check
> Seems that this will not happen on my fedora10-vms at home
>
> The problem was on F9-guests in our company last night and after the second one
> i switched to "rpm" instead of "yum" an wondered how fast it runs

Symptoms match those of bug 472507, and yes it's fixed in rpm of F10 updates-testing if you're using that. The fix hasn't been backported to rpm 4.4.x yet though.
Comment 4 seth vidal 2009-01-21 14:04:00 EST

*** This bug has been marked as a duplicate of bug 472507 ***

Note You need to log in before you can comment on or make changes to this bug.