Bug 477578 - Missing octet-stream configuration breaks remote OO printing on HP printer.
Missing octet-stream configuration breaks remote OO printing on HP printer.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 00:53 EST by Gilboa Davara
Modified: 2008-12-23 12:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 07:26:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2008-12-22 00:53:57 EST
Description of problem:
As the title suggests, I'm trying to print a document from oowriter on an F10 machine to a multi-function HP printer/FAX (Officejet J5783) running on an F9 server.
Job get rejected due to invalid octet stream.
Following a search on the Internet, I uncommented "application/octet-stream    application/vnd.cups-raw    0   -" in /etc/cups/cups.convs on both machine and printing was successful.

I can't say that I fully understand cups, mime type handling, but as far as I understand, the mime-type (octet-stream) is supported, but the "conversion" to raw printing isn't. (Due to commented line.)

Version-Release number of selected component (if applicable):
F9:
$ rpm -q cups
cups-1.3.9-3.fc9.x86_64
F10:
$ rpm -q cups
cups-1.3.9-6.fc10.x86_64

- Gilboa
Comment 1 Tim Waugh 2008-12-22 07:26:23 EST
Are you really intending to have the Fedora 10 machine convert the print job to a raster format and send it as a raw job?  It's not the usual way of doing it, which is why that line is commented by default (as well as to prevent wasting paper/ink with silly mistakes).

Normally you'd have the client machine submit the job in some common format such as PostScript or PDF, and then the print server machine would convert that into the printer's native language.
Comment 2 Gilboa Davara 2008-12-22 08:28:32 EST
I can't say that I understand the reason for it, but it seems that if/why, but it seems that OO (in its default configuration), when combined with the HP OfficeJet j5700 Foomatic/hpijs driver (on both cups client and cups server), defaults to raw format.

I can only assume that the local drivers takes the PS file, converts it raw format and sends it to the remote cups server. (And I most likely totally wrong)

- Gilboa
Comment 3 Tim Waugh 2008-12-22 08:43:23 EST
No, it's not anything to do with OpenOffice.org.  Your local CUPS queue, for passing the job to the CUPS server, seems to be set up incorrectly -- that's why I've closed this as NOTABUG.

Out of curiosity, how did you configure it?
Comment 4 Gilboa Davara 2008-12-23 07:52:01 EST
Ummm... 
I configure the remote machine more-or-less the same as local ones - read:
New printer -> IPP -> put host -> put queue name -> select driver (HP Officejet j5700) -> save.

Was I supposed to do something else? I've been doing it for -years- now... (Why do I have a feeling that I'm going to be named to idiot of the year. /ducks.)

- Gilboa
Comment 5 Tim Waugh 2008-12-23 09:05:44 EST
You want to select 'Raw Queue' for the driver.  If you use system-config-printer it should do this automatically for you (at least, the current update for Fedora 9 does for me).

This gives the job to the remote CUPS
Comment 6 Tim Waugh 2008-12-23 09:06:26 EST
..server straight from the application, without modifying it.
Comment 7 Gilboa Davara 2008-12-23 09:26:01 EST
OK. Thanks. I'll reconfigure the clients to use raw printing.
Side question - shouldn't octet-stream be enabled for non-Cups clients? (Read: Windows?) I don't remember seeing raw printing in Windows. (Though I may be wrong)

- Gilboa
Comment 8 Tim Waugh 2008-12-23 09:39:39 EST
Our samba server knows to submit the jobs using the 'raw' job option, so that should already be doing the right thing.

Alternatively, using a generic PostScript driver (or the CUPS
Comment 9 Tim Waugh 2008-12-23 09:40:14 EST
...Windows driver) would also work.
Comment 10 Gilboa Davara 2008-12-23 12:00:54 EST
OK .Thanks.

- Gilboa

Note You need to log in before you can comment on or make changes to this bug.