Bug 477591 - python-storm test suite fails in rawhide with Python 2.6
python-storm test suite fails in rawhide with Python 2.6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-storm (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 03:22 EST by Alex Lancaster
Modified: 2009-09-08 21:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.15-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 21:52:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 310520 None None None Never

  None (edit)
Description Alex Lancaster 2008-12-22 03:22:39 EST
Test suite currently fails:

https://koji.fedoraproject.org/koji/taskinfo?taskID=1015672

Version-Release number of selected component (if applicable): python-storm-0.13-3

I have temporarily disabled %check in the .spec and rebuilt to fix the broken deps in rawhide.  Opening this bug to remind me and the main maintainer to come back and fix it later.
Comment 1 Alex Lancaster 2008-12-22 03:41:19 EST
Upstream thinks it's relatively safe to disable for the moment and have opened up a bug to track this:

https://launchpad.net/bugs/310520
Comment 2 James Henstridge 2009-02-03 04:57:42 EST
I've tracked down the cause of this bug and added a description of it in the upstream tracker.  I'll look at getting it fixed for the next release (0.15).
Comment 3 Michel Alexandre Salim 2009-02-11 09:01:35 EST
James: if you check in a fix before 0.15 that can be easily backported, do let us know too. Thanks.
Comment 4 James Henstridge 2009-02-19 20:52:34 EST
The change has been committed to trunk in r295, so will be included in 0.15.  Here's a link to the changes:

  http://bazaar.launchpad.net/~storm/storm/trunk/revision/295
Comment 5 Bug Zapper 2009-06-09 06:28:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Michel Alexandre Salim 2009-08-28 22:11:20 EDT
With 0.15, the tests now run successfully on F-11 and above, but SQLite tests are failing on F-10 and EL-5.
Comment 7 Fedora Update System 2009-08-28 22:37:43 EDT
python-storm-0.15-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-storm-0.15-2.fc11
Comment 8 Fedora Update System 2009-08-31 19:44:05 EDT
python-storm-0.15-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-storm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9202
Comment 9 Fedora Update System 2009-09-08 21:52:21 EDT
python-storm-0.15-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.