Bug 477607 - mkfontscale produces syscalls with EINVAL
mkfontscale produces syscalls with EINVAL
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 07:02 EST by Steve Grubb
Modified: 2008-12-22 12:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 12:47:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing problems described herein (606 bytes, patch)
2008-12-22 07:02 EST, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2008-12-22 07:02:52 EST
Created attachment 327635 [details]
patch fixing problems described herein

Description of problem:
The mkfontscale program uses the freetype library. Our IDS work shows that the freetype library causes mmap syscalls with EINVAL return codes. This is because its not checking the length of the file before calling mmap. If the file is opened readonly and the length is 0, the kernel does not like it.


How reproducible:
always

Steps to Reproduce:
1. add to audit rules: -a always,exit -S mmap -F exit=-ENIVAL -k einval
2. reboot system
3. ausearch --start recent -k einval
Comment 1 Behdad Esfahbod 2008-12-22 12:47:53 EST
Reported upstream:
http://savannah.nongnu.org/bugs/?25151

Note You need to log in before you can comment on or make changes to this bug.