Bug 477613 - Changes name of waypoint on upload to garmin
Changes name of waypoint on upload to garmin
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: gpsbabel (Show other bugs)
el5
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Roozbeh Pournader
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 08:34 EST by Michael A. Peters
Modified: 2009-01-12 12:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 12:11:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2008-12-22 08:34:47 EST
Description of problem:
If I have a waypoint on my garmin that includes a "-" character - and I use gpsbabel to download the waypoint from the garmin to a gpx file, the - character is preserved. However, if I upload a waypoint with a "-" character from a gpx file to the garmin, the - character gets lost.

IE -

NOR-RR-CUT

in the gpx file becomes

NORRRCUT

on the garmin.


Version-Release number of selected component (if applicable):
gpsbabel-1.3.3-1.el5

Garmin eTrex Legend
connected via serial port



How reproducible:
always


Steps to Reproduce:
1. create a gpx file with a waypoint that has a - in the name
2. gpsbabel -i gpx -f somefile.gpx -o garmin -F /dev/ttyS0
3.
  
Actual results:
The waypoint on the garmin does not contain the -

Expected results:
The waypoint on the garmin should contain the -


Additional info:

For now I can just use spaces instead of - as a delimiter, but it "would" be nice if it was fixed.

Software version on the garmin:3.70
Comment 1 Roozbeh Pournader 2009-01-08 10:51:42 EST
I haven't been using gpsbabel for a while. I think I should release the package. silfreed?
Comment 2 Douglas E. Warner 2009-01-08 11:47:03 EST
Roozbeh, let me know if you'd like me to take over the package, I wouldn't mind.  I would appreciate it if you could stay on as contributor in case questions come up, though.

Michael, I'll ask upstream to see if this is intended/expected behavior.
Comment 3 Michael A. Peters 2009-01-08 17:22:16 EST
Someone told me this issue is known by gpsbabel and is related to the proprietary nature of garmin, I'm looking through the gpsbabel lists to try and find reference - but if that's the case there may not be anything that can be done about it. I kind of wonder if it is UTF8/character encoding related, IE maybe garmin uses a custom character encoding.

I'll try to find more info.
Comment 4 Douglas E. Warner 2009-01-12 12:11:38 EST
I haven't heard back whether this is intended/expected behaviour, but I believe it's a problem with the Garmin protocol as you stated.

Closing as wontfix for now; feel free to reopen if you find more information out.

Note You need to log in before you can comment on or make changes to this bug.