Bug 477621 - java clustering Feature request (IG Index)
java clustering Feature request (IG Index)
Status: CLOSED DUPLICATE of bug 483753
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Rajith Attapattu
Frantisek Reznicek
IG Index
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 09:53 EST by Arnaud Simon
Modified: 2015-11-15 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 17:34:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud Simon 2008-12-22 09:53:15 EST
Currently java clustering requires to statically set the list of cluster nodes within the connection URL. The only way of achieving a kind of load balancing is by manually randomizing the list. Several improvements could be made:
          o The java library should randomly pickup one node name. This would allow to use a single deployment file for all the clients.
          o The java library should update the list of nodes when a new node is added in the cluster. That is to say that the java client should handle the clustering management messages and somehow persist the updated list of broker nodes.
          o A less important but very nice to have feature would be for the java client library to gather information on the node loads at connection time. The client library would then use a pluggable heuristic to decide on which node of the cluster it should potentially reconnect.
Comment 1 Rajith Attapattu 2009-02-09 17:34:02 EST

*** This bug has been marked as a duplicate of bug 483753 ***

Note You need to log in before you can comment on or make changes to this bug.