Bug 477655 - Irq 16 disabled, mouse slow, can't shut down properly.
Irq 16 disabled, mouse slow, can't shut down properly.
Status: CLOSED DUPLICATE of bug 474624
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 13:19 EST by Tom Bjerck
Modified: 2009-04-14 08:49 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 08:49:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg file (36.84 KB, text/plain)
2008-12-22 13:26 EST, Tom Bjerck
no flags Details
/var/log/messages (9.15 KB, text/plain)
2008-12-22 13:28 EST, Tom Bjerck
no flags Details
Output of lspci -nn (2.39 KB, text/plain)
2008-12-22 13:30 EST, Tom Bjerck
no flags Details
Xorg.0.log.old (83.88 KB, text/plain)
2008-12-22 13:35 EST, Tom Bjerck
no flags Details
Output of cat /proc/interrupts (1.26 KB, text/plain)
2008-12-22 19:32 EST, Tom Bjerck
no flags Details
dmesg (25.46 KB, text/plain)
2008-12-31 00:51 EST, João Carlos Mendes Luís
no flags Details
Output of cat /proc/interrupts (1000 bytes, text/plain)
2008-12-31 00:54 EST, João Carlos Mendes Luís
no flags Details
Output of lspci -nn (1.52 KB, text/plain)
2008-12-31 00:58 EST, João Carlos Mendes Luís
no flags Details

  None (edit)
Description Tom Bjerck 2008-12-22 13:19:36 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

First indication that something is wrong is that the mouse pointer gets very slow. Then a message in /var/log/messages:
kernel: irq 16: nobody cared (try booting with the "irqpoll" option)
[...]
kernel: Disabling IRQ #16
The machine will not shut down properly after this error, and a hard shutdown with the power button is neccessary.



Reproducible: Sometimes

Steps to Reproduce:
1. Boot Fedora 10.
2. Log in.
3. After minutes or hours irq 16 may be disabled.
Actual Results:  
Mouse becomes slow. Irq 16 disable. System can not shut down properly.

Expected Results:  
Mouse working smoothly. Irq 16 not disabled. Be able to shut down system properly.
Comment 1 Tom Bjerck 2008-12-22 13:26:06 EST
Created attachment 327677 [details]
dmesg file
Comment 2 Tom Bjerck 2008-12-22 13:28:07 EST
Created attachment 327678 [details]
/var/log/messages
Comment 3 Tom Bjerck 2008-12-22 13:30:12 EST
Created attachment 327679 [details]
Output of lspci -nn
Comment 4 Tom Bjerck 2008-12-22 13:33:29 EST
This error was produced on a Lenovo Thinkpad R61e.
Comment 5 Tom Bjerck 2008-12-22 13:35:41 EST
Created attachment 327680 [details]
Xorg.0.log.old
Comment 6 Tom Bjerck 2008-12-22 19:32:00 EST
Created attachment 327718 [details]
Output of cat /proc/interrupts
Comment 7 Tom Bjerck 2008-12-22 19:49:40 EST
No devices are plugged into any USB or PCMCIA slots.
Comment 8 João Carlos Mendes Luís 2008-12-31 00:43:17 EST
I am pretty sure my problem is connected to this one.

I have a Dell Optiplex GX270, with the latest BIOS updates and a Maxtor SATA Disk.

I was trying to install Fedora 10 in it, and everything was going ok, until I reboot for the first time.  I got a "Disabling IRQ #18" message on the console, and after that the disk freezes, freezing also the whole shutdown process.

After some debugging I found that I could easily reproduce the error by shutting down the network (service network stop), and sometimes can get the disk back to life by restarting the network (issuing a service network start).
Comment 9 João Carlos Mendes Luís 2008-12-31 00:51:02 EST
Created attachment 327990 [details]
dmesg

This dmesg has been generated in a boot with options "noapic irqpoll irqfixup"

Note that the noapic option only changed the trouble IRQ number, but solved no problem at all.

Also, note that I have no USB device connected, so the IRQ competition is only between e1000 and sata piix.
Comment 10 João Carlos Mendes Luís 2008-12-31 00:54:48 EST
Created attachment 327991 [details]
Output of cat /proc/interrupts

Note the very high count of network/sata interrupts.  They have raised a lot after the "service network stop" command.  BTW, this remembers me: For some seconds the keyboard was not responsive after this command, probably because of the interrupt storm.
Comment 11 João Carlos Mendes Luís 2008-12-31 00:58:55 EST
Created attachment 327992 [details]
Output of lspci -nn

Just in case...

As you can see, it just a plain simple Intel computer.  If only Dell let me have some more BIOS options...
Comment 12 Thorsten Leemhuis 2009-01-15 12:43:11 EST
@Tom: you problem looks a lot like a dupe of Bug 474624
Comment 13 François Cami 2009-02-16 04:59:37 EST
Tom,

Could you please try each of the following kernel arguments and report :
noirqdebug
pci=msi

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Adrian A. Sender 2009-03-03 05:58:52 EST
I also am experiencing the same issue on Lenovo T61 Fedora 10 x86. Please email me if you require further details.
Comment 15 Adrian A. Sender 2009-03-03 06:03:04 EST
Looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=474624
Comment 16 Charles R. Anderson 2009-04-14 08:49:45 EDT
pci=msi needs a newer kernel to fix this issue, probably 2.6.29, because the
2.6.27 kernel forcibly disables MSI on the GMA965 graphics chip, even with
pci=msi.  I'm closing this as a duplicate of #474624.

*** This bug has been marked as a duplicate of bug 474624 ***

Note You need to log in before you can comment on or make changes to this bug.