Bug 477677 - boingmgr emits on startup: Xlib: extension "Generic Event Extension" missing on display "localhost:10.0".
boingmgr emits on startup: Xlib: extension "Generic Event Extension" missing...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 15:55 EST by Christopher Beland
Modified: 2014-06-18 05:10 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.0.99.1-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 19:31:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (64.31 KB, text/plain)
2009-01-15 14:01 EST, Christopher Beland
no flags Details
xorg.conf (593 bytes, text/plain)
2009-01-15 14:01 EST, Christopher Beland
no flags Details
.xsession-errors.XXAMSLNU (9.62 KB, text/plain)
2009-01-15 14:04 EST, Christopher Beland
no flags Details

  None (edit)
Description Christopher Beland 2008-12-22 15:55:16 EST
I normally have boinc-client started as a system service, then log in as "boinc" and type "boincmgr" to get the GUI.  This worked fine until the update to boinc-client-6.2.15-2.20080818svn.fc11.  Now I get errors in my xterm:

>>
Xlib:  extension "Generic Event Extension" missing on display "localhost:11.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:11.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:11.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:11.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:11.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:11.0".
connect: Operation now in progress
<<

When boincmgr starts up, it shows the status "Disconnected" and I can't access any of my tasks or accounts.
Comment 1 Christopher Beland 2008-12-22 16:15:03 EST
I moved the files boinc had been dumping in /home/boinc to /var/lib/boinc, then did the "Select computer" step as recommended by:

 https://fedoraproject.org/wiki/User:Mjakubicek/HowToUseBoinc

I can now see my accounts and tasks.  It seems like either this change should be handled more smoothly for people who are upgrading, or something should be added to the release notes.
Comment 2 Christopher Beland 2008-12-22 16:17:18 EST
I should add that I still get the xterm errors.
Comment 3 Milos Jakubicek 2008-12-22 16:56:54 EST
>It seems like either this change should be handled more smoothly for people who >are upgrading, or something should be added to the release notes.

I really wonder that it worked for you in the way you described: that was *never* an intended or recommended usage and I assume you had to tweak the default configuration a bit, am I right? (E.g. you can't log in as boinc user since the login shell is set to /sbin/nologin and BOINC has /var/lib/boinc as data directory by default, which can be properly changed in the init script).

You can't be surprised that an update breaks such weird configuration, I'm sorry.

>I should add that I still get the xterm errors.

I'm afraid this is BOINC unrelated and happened just because BOINC has been rebuilt against current libX* on rawhide. On F10 (but same BOINC release) I'm getting only once "connect: Operation now in progress" as usual.

The first hit on Google shows some recent complains about similar messages:
http://lists.freedesktop.org/archives/xorg/2008-October/039131.html

=> I'm forwarding this to the libX11 component, maybe we'll get an answer there:)
Comment 4 Christopher Beland 2008-12-22 17:34:38 EST
I think I originally started out with a tarball and upgraded to the boinc-client RPM at some point.  Perhaps it was a coincidence that I had already set up the "boinc" user with login enabled, and that user was recycled by the RPM.  As long as folks who have always used the recommended configuration won't be inconvenienced, I'll just take the bumpy upgrade as a local problem.

It would be nice if the RPM contained documentation explaining what the recommended procedures are, or at least a prominent link to a useful URL.

https://fedoraproject.org/wiki/User:Mjakubicek/HowToUseBoinc

was an excellent starting point, or I've also just updated:

http://boinc.berkeley.edu/wiki/Installing_BOINC_on_Fedora
Comment 5 Milos Jakubicek 2008-12-22 18:07:43 EST
(In reply to comment #4)

> It would be nice if the RPM contained documentation explaining what the
> recommended procedures are, or at least a prominent link to a useful URL.
> 
> https://fedoraproject.org/wiki/User:Mjakubicek/HowToUseBoinc

Agree, I'm preparing a 6.4.5 release now, I'll include it as %doc.
Comment 6 Christopher Beland 2008-12-24 13:27:48 EST
Awesome; 6.4 will also fix another one of my bugs, yay!
Comment 7 Christopher Beland 2009-01-02 22:33:50 EST
So I did "rpm -e boinc-client boinc-manager boinc-client-debuginfo" and "userdel boinc" and removed all the remaining boinc-related files I could find.  Then I installed:

boinc-client-6.4.5-1.20081217svn.fc10.x86_64
boinc-manager-6.4.5-1.20081217svn.fc10.x86_64
boinc-client-debuginfo-6.4.5-1.20081217svn.fc10.x86_64

After "/sbin/service boinc-client start" as root", I ran "boincmgr" as beland.  I got the GUI, but after a few seconds, it just displays a big red "X Error" and says "Unable to connect to the core client".  It is unclear what the user is supposed to do next.
Comment 8 Christopher Beland 2009-01-03 18:13:44 EST
I'm splitting this bug for ease of tracking.  I'll leave the Xlib problem here, since it's already been reassigned, and move connection problems to Bug 478715 - Usability problems connecting boincmgr to boinc-client.  Sorry for any confusion.
Comment 9 Matěj Cepl 2009-01-15 13:30:31 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), X server log file (/var/log/Xorg.*.log), and ~/.xsession-errors to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 10 Christopher Beland 2009-01-15 14:01:08 EST
Created attachment 329128 [details]
/var/log/Xorg.0.log
Comment 11 Christopher Beland 2009-01-15 14:01:45 EST
Created attachment 329129 [details]
xorg.conf
Comment 12 Christopher Beland 2009-01-15 14:04:26 EST
Created attachment 329130 [details]
.xsession-errors.XXAMSLNU

I noticed just now that the Xlib error is produced when I start boincmgr (or gimp or emacs) remotely in a session started with "ssh -Y" (from a Fedora 9 laptop), but not when started from an xterm on a local X login.
Comment 13 Peter Hutterer 2009-04-16 19:31:35 EDT

*** This bug has been marked as a duplicate of bug 478607 ***
Comment 14 Fedora Update System 2009-09-01 20:22:21 EDT
libXext-1.0.99.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libXext-1.0.99.1-3.fc11
Comment 15 Fedora Update System 2009-09-09 23:47:23 EDT
libXext-1.0.99.1-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.