Bug 47768 - Machine hangs during startx on S3 ProSavage KM133 video
Machine hangs during startx on S3 ProSavage KM133 video
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 19:42 EDT by NILMONI DEB
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-16 23:50:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NILMONI DEB 2001-07-06 19:42:34 EDT
Description of Problem:
Machine hangs when doing startx on S3 ProSavage KM133 integrated video
(on K7VMA motherboard). Its so badly hung that:

1.I can't switch virtual consoles.
2.Ping from a remote pc to the hung machine failed which means I just couldnot access the /var/log/XFree86.0.log file.
3.Only choice was hardware reset so that I could not save the /var/log/XFree86.0.log file at the next reboot.

I have faced this problem with both X-4.0.3 and X-4.1.0 .

How Reproducible:
always

Steps to Reproduce:
1. startx
2. 
3. 

Actual Results:
hung machine

Expected Results:
proper X environment

Additional Information:
Comment 1 Mike A. Harris 2001-07-12 01:44:57 EDT
Set your system to boot in runlevel 3 if it is not already.  It is
critical that I get server log from you in order to diagnose this.
What version of XFree86 are you using now?  The latest is 4.0.3-22.5

Pleas attach an uncompressed log file from /var/log/XFree86.0.log
and also the messages log file (do not post a large file, trim it down please).

Use the link below to make file attachments.
Comment 2 NILMONI DEB 2001-07-12 11:37:25 EDT
It is already set at run-level 3 (text based login). I am using X-4.1.0. I contacted Tim of http://www.probo.com/timr/savage40.html and learnt that X-4.1.0 has their latest 1.1.7 driver.



Its nearly impossible for me to get the server log as the whole system crashes when I just run "X". I can't ssh or telnet to the crashed machine from a remote machine. I made a workaround this way. I kept a remote ssh session running a "tail -f Xfree86.0.log" and then ran X.  The crash occurred just after this last log message ->



(II) Loading /usr/X11R6/lib/modules/drivers/savage_drv.o



Right now thats the best I can do. Also lspci gives:



01:00.0 VGA compatible controller: S3 Inc.: Unknown device 8a26

Comment 3 Mike A. Harris 2001-07-22 18:07:16 EDT
When your system crashes, the XFree86.0.log should remain intact.  It
may get blown away somehow, but usually it is still intact.  I now need
the output of "lspci -v" and "lspci -vn" from you.
Comment 4 NILMONI DEB 2001-07-22 18:18:18 EDT
lspci -v  output:

01:00.0 VGA compatible controller: S3 Inc.: Unknown device 8a26 (prog-if 00 [VGA])
        Flags: 66Mhz, medium devsel, IRQ 5
        Memory at e1000000 (32-bit, non-prefetchable) [disabled] [size=512K]
        Memory at d0000000 (32-bit, prefetchable) [disabled] [size=128M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: <available only to root>


lspci -vn output:

01:00.0 Class 0300: 5333:8a26
        Flags: 66Mhz, medium devsel, IRQ 5
        Memory at e1000000 (32-bit, non-prefetchable) [disabled] [size=512K]
        Memory at d0000000 (32-bit, prefetchable) [disabled] [size=128M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: <available only to root>
Comment 5 Mike A. Harris 2001-07-23 02:09:10 EDT
This chipset appears to have some code in 4.1.0 but it does not appear
complete. The Status document for 4.1.0 does not list it as a supported
chipset (ProSavage). I have emailed the author to get details. If the
chip is in fact supported, then I may add it to Xconfigurator et al.

I'll update this when I hear back from Tim.
Comment 6 Mike A. Harris 2001-07-31 07:13:55 EDT
Aparently it is supposed to be supported at least partially, but
there are reports of problems from a few people.  Since it is not
listed on the support doc, and there are known probs, I consider it
a low priority problem right now.  Will look into this again in the 
future though when I hear more from Tim.
Comment 7 NILMONI DEB 2001-08-16 23:50:22 EDT
With the latest (1.1.18) savage driver from 
http://www.probo.com/timr/savage40.html
the lockup problem is not there anymore.
Comment 8 Mike A. Harris 2001-11-05 08:20:10 EST
Great, closing bug, as our current driver is 1.1.20t and others have
reported the problem is fixed now also.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.