Bug 477690 - libchewing multilib conflict
libchewing multilib conflict
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libchewing (Show other bugs)
17
All Linux
low Severity medium
: ---
: ---
Assigned To: Ding-Yi Chen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 17:25 EST by Philippe Troin
Modified: 2012-08-28 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 19:30:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2008-12-22 17:25:01 EST
Description of problem:

yum install libchewing.i386 libchewing.x86_64

yeilds:

  file /usr/share/chewing/fonetree.dat from install of libchewing-0.3.2-0.fc10.i386 conflicts with file from package libchewing-0.3.2-0.fc10.x86_64

Version-Release number of selected component (if applicable):
libchewing-0.3.2-0.fc10
Comment 1 Fedora Update System 2008-12-23 02:24:31 EST
libchewing-0.3.2-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-2.fc10
Comment 2 Fedora Update System 2008-12-23 02:24:36 EST
libchewing-0.3.2-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-2.fc9
Comment 3 Ding-Yi Chen 2008-12-23 02:25:00 EST
Fixed.

/usr/share/chewing/fonetree.dat is moved to %{_libdir}/chewing

Regards,
Ding-Yi Chen
Comment 4 Fedora Update System 2008-12-24 13:42:38 EST
libchewing-0.3.2-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libchewing'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11762
Comment 5 Fedora Update System 2008-12-24 13:43:34 EST
libchewing-0.3.2-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update libchewing'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11767
Comment 6 Fedora Update System 2009-01-07 04:12:57 EST
libchewing-0.3.2-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-01-14 07:40:45 EST
libchewing-0.3.2-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libchewing-0.3.2-3.fc10
Comment 8 Fedora Update System 2009-02-04 21:16:37 EST
libchewing-0.3.2-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-02-04 21:22:24 EST
libchewing-0.3.2-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Philippe Troin 2012-06-12 18:59:15 EDT
Reintroduced at some point:

# yum install libchewing
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Package libchewing-0.3.3-2.fc17.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package libchewing.i686 0:0.3.3-2.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch          Version                Repository       Size
================================================================================
Installing:
 libchewing          i686          0.3.3-2.fc17           fedora          2.1 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 2.1 M
Installed size: 7.1 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/share/chewing/fonetree.dat from install of libchewing-0.3.3-2.fc17.i686 conflicts with file from package libchewing-0.3.3-2.fc17.x86_64

Error Summary
-------------

[2]    12224 exit 1     noglob yum install libchewing
Comment 11 Fedora Update System 2012-07-19 17:58:24 EDT
libchewing-0.3.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libchewing-0.3.3-3.fc17
Comment 12 Fedora Update System 2012-07-19 17:58:34 EDT
libchewing-0.3.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libchewing-0.3.3-3.fc16
Comment 13 Fedora Update System 2012-07-20 22:50:54 EDT
Package libchewing-0.3.3-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libchewing-0.3.3-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10914/libchewing-0.3.3-3.fc17
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-08-28 19:30:39 EDT
libchewing-0.3.3-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2012-08-28 19:35:11 EDT
libchewing-0.3.3-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.