Bug 477701 - Exported content from Hosted need to conform to Satellite schema (e.g., errata description not exceeding 4k chars)
Exported content from Hosted need to conform to Satellite schema (e.g., errat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn508
All Linux
high Severity high
: ---
: ---
Assigned To: Bryan Kearney
Denise Hughes
us=69692
:
Depends On:
Blocks: 428922 GSS_HOSTED_Tracker 477703 rhn-sprint22
  Show dependency treegraph
 
Reported: 2008-12-22 18:14 EST by Xixi
Modified: 2013-01-10 04:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 09:25:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2008-12-22 18:14:57 EST
Description of problem:
In the case of different character encodings, content exported from Hosted may exceed Satellite schema, causing satellite-sync failure.

Example:
Recently due to special characters in Errata Description of erratum https://rhn.redhat.com/rhn/errata/details/Details.do?eid=7924, the exported content exceeded 4000 char limit causing all (pre-5.2) Satellite-syncs to fail for RHEL 5 channels.

Bug 476751 -  ValueError: string data too large
and 
Bug 476756 -  sat-sync unhandled exception 1461, 'ORA-01461: can bind a LONG
value only for insert into a LONG columnn'

The short term fix was to reduce char count for the description of the erratum in question even further.  For the long-term fix on the export side, need to make sure the exported content conforms to the schema on import side (errata description is one specific field, this needs to be done in general).

Version-Release number of selected component (if applicable):
Current (5.0.8)

How reproducible:
See example above.

Steps to Reproduce:
1. See example above.
2.
3.
  
Actual results:
See example above.

Expected results:
Regardless of character encoding, the exported content from Hosted should conform to schema on importer side (Satellite). 

Additional info:
Comment 4 Denise Hughes 2009-05-05 10:56:14 EDT
Verified in dev.
Comment 5 Denise Hughes 2009-05-18 09:25:12 EDT
Pushed to prod on 5/15/09.

Note You need to log in before you can comment on or make changes to this bug.