Bug 477726 - Synaptics kernel driver exports wrong multifinger option
Synaptics kernel driver exports wrong multifinger option
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 23:09 EST by Peter Hutterer
Modified: 2009-07-30 20:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-30 20:09:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hutterer 2008-12-22 23:09:39 EST
Description of problem:
The synaptics driver exports the wrong multifinger option for some devices. 

The multifinger support is hardcoded without checking the hardware first and all touchpads thus announce capabilities for two-finger or three-finger touch. The xorg-x11-drv-synaptics driver (version 1.0) relies on the multifinger capabilities to set up two-finger or edge scrolling. If the information is wrong, the driver will setup two-finger scrolling only - even though the touchpad can't actually do it. As a result, scrolling is broken.

This bug has been in the kernel since at least the import into git.  
A patch has been provided: http://lkml.org/lkml/2008/11/19/376
The patch was in -mm and is now in linux-next. It'd be good if we can pull this patch into F10 and rawhide to allow the upgrade to xorg-x11-drv-synaptics 1.0 when it comes out.

Version-Release number of selected component (if applicable):
All up to 2.6.27

How reproducible:
Use a Lenovo T61, run evtest against the synaptics device. The synaptics pretends to have multi-finger capabilities even though it can't actually detect multi-finger touches.
Comment 1 Peter Hutterer 2009-07-30 20:09:50 EDT
Works in F11.

Note You need to log in before you can comment on or make changes to this bug.