Bug 477756 - Incorrect LANG environment variable handling
Incorrect LANG environment variable handling
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkspell (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 06:20 EST by Tomáš Windsor
Modified: 2009-01-07 04:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:06:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Windsor 2008-12-23 06:20:42 EST
Description of problem:
Locales starting with char 'C' are not correctly detected from the LANG environment variable.

Version-Release number of selected component (if applicable):
2.0.13-1.fc10

How reproducible:
E.g. on Tomboy application.

Steps to Reproduce:
1. export LANG=cs_CZ.UTF-8
2. tomboy
  
Actual results:
Czech spellchecker not working in Tomboy.

Expected results:
Czech spellchecker working in Tomboy.

Additional info:
Seems to be caused by following part of code in gtkspell.c

static gboolean
gtkspell_set_language_internal(GtkSpell *spell, const gchar *lang, GError **error) {

	if (lang == NULL) {
		lang = g_getenv("LANG");
		if (lang) {
			if (g_strncasecmp(lang, "C", 1) == 0)
				lang = NULL;
			else if (lang[0] == 0)
				lang = NULL;
Comment 1 Fedora Update System 2008-12-23 08:13:52 EST
gtkspell-2.0.15-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gtkspell-2.0.15-1.fc10
Comment 2 Fedora Update System 2008-12-24 13:45:50 EST
gtkspell-2.0.15-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkspell'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11794
Comment 3 Fedora Update System 2009-01-07 04:06:44 EST
gtkspell-2.0.15-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.