Bug 47776 - nautilus locks up for non-root users.
nautilus locks up for non-root users.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 23:33 EDT by Sam Varshavchik
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 21:00:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2001-07-06 23:33:05 EDT
For a non-root user, clicking on any nautilus icon locks up nautilus.

After starting nautilus, I can click on the desktop background and open new
filesystem browser windows without a problem.  Clicking on an icon for any
file in any browser window, or clicking on any nautilus icon on the window
desktop, locks up nautilus for about two minutes, before nautilus
highlights the icon.

This does not happen for root.
Comment 1 Havoc Pennington 2001-07-12 11:33:15 EDT
If you run "esd" in a terminal does it work again?
Comment 2 Sam Varshavchik 2001-07-12 17:23:03 EDT
This machine does not have a sound card.

Comment 3 Havoc Pennington 2001-07-12 17:51:51 EDT
That doesn't matter; just humor me and see if running esd helps ;-)

If it doesn't, can you "strace -p -o foo" the nautilus process during the
lockup, gzip foo, and send foo.gz to hp@redhat.com?
Thanks!
Comment 4 Glen Foster 2001-07-13 15:45:18 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 5 Sam Varshavchik 2001-07-13 20:59:59 EDT
esd will not run because it will fail to /dev/dsp, since there is no sound card.

Run esd when logged in as non-root

nautilus locks up

Log out.

Log in as root.

rm -rf root-owned /tmp/esd

Log out.

Log in as non-root.

nautilus locks up

Log out, use a root window to kill all the stuck non-root processes that weren't
killed.

Log in as non-root.

Run esd, creating non-root owned /tmp/.esd

nautilus works.

strace when nautilus locks up follows.

Comment 6 Havoc Pennington 2001-07-19 19:34:21 EDT
The strace and your comments indicate this was an esd problem we fixed, so I
think this should be gone. Please reopen if you can still reproduce with rawhide
nautilus and esound.

Thanks for the thorough report.

Note You need to log in before you can comment on or make changes to this bug.