Bug 477764 - /sbin/restorecon generate coredump when truing restore /var/run/sm-client.pid
/sbin/restorecon generate coredump when truing restore /var/run/sm-client.pid
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 09:24 EST by Artur Penttinen
Modified: 2009-06-26 15:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fedora 10
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 15:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace log and content of /etc/selinux/targeted/contexts/files (30.33 KB, application/octet-stream)
2009-01-07 01:39 EST, Artur Penttinen
no flags Details

  None (edit)
Description Artur Penttinen 2008-12-23 09:24:13 EST
Description of problem:


Version-Release number of selected component (if applicable):
policycoreutils-2.0.57-14.fc10.i386

How reproducible:

Try restart sendmail:

Steps to Reproduce:
1. sudo make -C /etc/mail restart
2.
3.
  
Actual results:

/sbin/restorecon generate coredump.

Expected results:

Will restart sendmail.

Additional info:

# gdb /sbin/restorecon core.*
...
Core was generated by `/sbin/restorecon /var/run/sm-client.pid'.
Program terminated with signal 11, Segmentation fault.
[New process 18690]
#0  0x400171eb in call_init () at dl-init.c:70
70            init (argc, argv, env);
(gdb) bt
#0  0x400171eb in call_init () at dl-init.c:70
#1  _dl_init (main_map=0x40029658, argc=2, argv=0xbfef1984, env=0xbfef1990) at dl-init.c:134
#2  0x4000788f in _dl_start_user () from /lib/ld-linux.so.2
(gdb)
Comment 1 Daniel Walsh 2008-12-23 11:19:21 EST
This seems like it might be caused by a lower layer library.  I have not heard of restorecon crashing for any reason.
Comment 2 Daniel Walsh 2008-12-23 11:19:51 EST
Does restorecon crash all the time or just when run within this make?
Comment 3 Artur Penttinen 2008-12-29 05:41:51 EST
yes:

# sudo /sbin/restorecon /var/run/sm-client.pid
[1]    21507 segmentation fault (core dumped)  sudo /sbin/restorecon /var/run/sm-client.pid
#
Comment 4 Daniel Walsh 2009-01-04 12:41:26 EST
What does 

# id -Z

Show?

Does this happen in permissive mode?
Comment 5 Artur Penttinen 2009-01-05 01:49:15 EST
# id -Z
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
#
Comment 6 Daniel Walsh 2009-01-05 15:25:53 EST
Does this happen if you are in permissive mode?

# setenforce 0
# sudo /sbin/restorecon /var/run/sm-client.pid

Could you also get the output from

# sudo strace /sbin/restorecon /var/run/sm-client.pid
Comment 7 Daniel Walsh 2009-01-05 15:27:38 EST
Also please attach the contents of 

/etc/selinux/targeted/contexts/files/

Might be something here causing the problem.

Does matchpatchcon /var/run/sm-client.pid

work?
Comment 8 Artur Penttinen 2009-01-07 01:36:54 EST
Hm. After enforcing to permissive mode (though it already was), all began to work normally.
Just in case I attach strace log and content of /etc/selinux/targeted/contexts/files/.

# matchpathcon /var/run/sm-client.pid
/var/run/sm-client.pid  system_u:object_r:sendmail_var_run_t:s0
#
Comment 9 Artur Penttinen 2009-01-07 01:39:19 EST
Created attachment 328349 [details]
Strace log and content of /etc/selinux/targeted/contexts/files
Comment 10 Daniel Walsh 2009-01-07 13:37:25 EST
So are you saying this blows up in enforcing mode and not in permissive mode?

I think you have a labeling problem, I would put the machine in permissive mode and the run 

# fixfiles restore

Note You need to log in before you can comment on or make changes to this bug.