Bug 477766 - Fails to start on F10 using KDE
Fails to start on F10 using KDE
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 09:33 EST by Steven M. Parrish
Modified: 2008-12-23 10:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-23 10:05:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven M. Parrish 2008-12-23 09:33:02 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Start eclipse
2.
3.
  
Actual results:  Nothing happens


Expected results:  Eclipse starts


Additional info:

-consolelog -debug    output.

[steven@pegasus .eclipse]$ eclipse -consolelog -debug
Start VM: /usr/bin/java                              
-Xms40m                                              
-Xmx512m                                             
-XX:MaxPermSize=128m                                 
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding                   
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile    
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles       
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins                                  
-jar /usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20080819.jar                           
-os linux                                                                                                         
-ws gtk                                                                                                           
-arch x86_64                                                                                                      
-showsplash                                                                                                       
-launcher /usr/lib64/eclipse/eclipse                                                                              
-name Eclipse                                                                                                     
--launcher.library /usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.101.R34x_v20080731/eclipse_1115.so
-startup /usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20080819.jar                                       
-exitdata 568014                                                                                                                  
-consolelog                                                                                                                       
-debug                                                                                                                            
-vm /usr/bin/java                                                                                                                 
-vmargs                                                                                                                           
-Xms40m                                                                                                                           
-Xmx512m                                                                                                                          
-XX:MaxPermSize=128m                                                                                                              
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith                                          
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>                             
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate                
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding                                   
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile                    
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles                       
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins                                                  
-jar /usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20080819.jar                                           
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith                                             
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>                                
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate                   
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding                                      
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile                       
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles                          
Install location:                                                                                                                 
    file:/usr/lib64/eclipse/                                                                                                      
Configuration file:                                                                                                               
    file:/usr/lib64/eclipse/configuration/config.ini loaded                                                                       
Configuration location:                                                                                                           
    file:/home/steven/.eclipse/org.eclipse.platform_3.4.0_793567567/configuration/                                                
Configuration file:                                                                                                               
    file:/home/steven/.eclipse/org.eclipse.platform_3.4.0_793567567/configuration/config.ini loaded                               
Shared configuration location:                                                                                                    
    file:/usr/lib64/eclipse/configuration/                                                                                        
Framework located:                                                                                                                
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.4.2.R34x_v20080826-1230.jar                                                
Framework classpath:                                                                                                              
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.4.2.R34x_v20080826-1230.jar                                                
Splash location:                                                                                                                  
    /usr/lib64/eclipse/plugins/org.fedoraproject.ide.platform_3.4.1/splash.bmp                                                    
Debug options:                                                                                                                    
    file:/home/steven/.eclipse/.options not found                                                                                 
Time to load bundles: 9                                                                                                           
Starting application: 1096                                                                                                        
!SESSION 2008-12-23 09:27:35.804 -----------------------------------------------                                                  
eclipse.buildId=M20080911-1700                                                                                                    
java.version=1.6.0_07                                                                                                             
java.vendor=Sun Microsystems Inc.                                                                                                 
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US                                                                     
Command-line arguments:  -os linux -ws gtk -arch x86_64 -consolelog -debug                                                        

!ENTRY org.eclipse.osgi 4 0 2008-12-23 09:27:37.117
!MESSAGE Application error                         
!STACK 1                                           
java.lang.UnsatisfiedLinkError: Cannot load 64-bit SWT libraries on 32-bit JVM
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:172)     
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:151)     
        at org.eclipse.swt.internal.C.<clinit>(C.java:21)                     
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)    
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)    
        at org.eclipse.swt.widgets.Display.<clinit>(Display.java:130)
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:509)
        at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
        at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:143)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:88)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1212)
Comment 1 Andrew Overholt 2008-12-23 09:40:04 EST
Here's your error right here:

"Cannot load 64-bit SWT libraries on 32-bit JVM"

:)  You're trying to use x86_64 Eclipse packages with a 32-bit JVM.  This is either a configuration issue on your machine (alternatives --config java) or something you're passing to the command (-vm <path to 32-bit JVM>).

If you don't mind, could you respond to your thread on fedora-list stating what the problem was just so others can benefit?  Thanks :)
Comment 2 Steven M. Parrish 2008-12-23 10:05:00 EST
I saw that myself after I posted this.  Removed the 32bit JRE and set the default to 64bit and everything is running fine.

Note You need to log in before you can comment on or make changes to this bug.